Bug 143737 - possible array index error
Summary: possible array index error
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libunwind (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-26 10:06 UTC by David Binderman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 23:21:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2004-12-26 10:06:51 UTC
Description of problem:

I just tried to compile package libunwind-0.98.2-2 from 
Redhat Fedora development tree on a 32 bit Athlon box.

The compiler said

dwarf/Gparser.c(529): warning #175: subscript out of range

The source code is

          && (rs->reg[UNW_TDEP_SP].where == DWARF_WHERE_SAME))

Upon investigation, array reg has 19 entries, and UNW_TDEP_SP seems
to have a value in excess of 140.

I'm not sure if this is a real bug or not, for the target ia64 machine.
Suggest code inspection for the ia64 case.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Johnston 2005-01-10 23:21:48 UTC
At present, libunwind is only being supported by Red Hat on ia64 for
the purpose of gdb stack unwinding.  It is not officially supported by
Red Hat for other systems, though it is documented to have minimal
capabilities on x86 and x86_64.  Regarding the problem cited, it
definitely appears to be a problem as you have noted.  For ia64, the
dwarf directory is not built so the problem is avoided.  The
recommendation is that you open a problem report directly with the
libunwind development team if you wish to use it on x86 or x86_64.

Comment 2 Jan Kratochvil 2007-01-23 16:33:39 UTC
For x86* libunwind please check its frysk
  http://sourceware.org/frysk/
fork downloadable as:
  cvs -d :pserver:anoncvs@sources.redhat.com:/cvs/frysk co libunwind
as there is ongoing x86* libunwind development.



Note You need to log in before you can comment on or make changes to this bug.