Bug 143741 - dhclient writes incorrect ntp configuration for dhcp
dhclient writes incorrect ntp configuration for dhcp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-26 11:32 EST by Henning Schmiedehausen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: dhcp-3.0.1-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 11:57:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Schmiedehausen 2004-12-26 11:32:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
(This bug should be filed under dhclient. However, dhclient is missing
from Bugzilla. So I file it here).

dhclient writes a ntp.conf file for NTP which contains the line

authenticate yes

However, since 4.2.0, ntp mo longer supports the "authenticate"
command which results in 

Dec 26 16:52:16 localhost ntpd[3084]: configure: keyword
"authenticate" unknown, line ignored

getting logged to the syslog. This is not a big deal, because
authentication is activated by default now, but the manual _should_
mention, that the popular "authenticate no" line to enable simple
network broadcasting no longer works, but must be replaced by

disable auth

Then multicast and broadcast for time will work again.

However, dhclient should write a correct ntp.conf file (omitting the
authenticate line).


Version-Release number of selected component (if applicable):
ntp-4.2.0.a.20040617

How reproducible:
Always

Steps to Reproduce:
1. Launch an DHCP client host where the DHCP server reports an NTP host
2. Look at the /etc/ntp.conf file
3. Look at the daemon syslog file
    

Actual Results:  No errors

Expected Results:  See above.

Additional info:
Comment 1 Harald Hoyer 2005-01-03 05:37:56 EST
$ rpm -qif /sbin/dhclient|fgrep Source
Group       : System Environment/Base       Source RPM:
dhcp-3.0.1-11.src.rpm
Comment 2 Jason Vas Dias 2005-01-03 09:23:15 EST
This problem is fixed in dhclient-3.0.1-14, which has been in
FC4/rawhide for nearly a month now.
The dhclient script now merges in only NEW server entries and
does not remove local clock server entries.
I'm kicking off the process of pushing it to FC3 upgrades .
Meanwhile, you can download it from:
  http://people.redhat.com/~jvdias/dhcp/FC3 
Comment 3 Jason Vas Dias 2005-01-05 11:57:52 EST
 Latest version is now dhcp-3.0.1-16, with the NTP (and other) fixes.
 You can download it from:
  http://people.redhat.com/~jvdias/dhcp/FC3 

Note You need to log in before you can comment on or make changes to this bug.