Bug 1437466 - "Error from server (NotFound): secrets "heketi-db-backup" not found" message seen in cns-deploy --abort operation
Summary: "Error from server (NotFound): secrets "heketi-db-backup" not found" message ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.5
Assignee: Raghavendra Talur
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1415600
TreeView+ depends on / blocked
 
Reported: 2017-03-30 11:31 UTC by Prasanth
Modified: 2018-12-06 19:40 UTC (History)
5 users (show)

Fixed In Version: cns-deploy-4.0.0-13.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:29:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Prasanth 2017-03-30 11:31:50 UTC
Description of problem:

During --abort operation, the following error message is seen:

#####
Error from server (NotFound): secrets "heketi-db-backup" not found
#####

Version-Release number of selected component (if applicable):
cns-deploy-4.0.0-10.el7rhgs.x86_64
heketi-client-4.0.0-5.el7rhgs.x86_64

How reproducible: Always


Steps to Reproduce:
1. Install cns-deploy
2. Create a new namespace called "storage-project"
3. Setup a router as described in our official doc
4. Populate a topology file
5. Deploy cns using the cns-deploy tool
6. Now try to abort the deployment 
     Ex# cns-deploy -g --abort --log-file=/var/log/latest-cns-deploy-abort-.log


Actual results: See the full console output which contains the error message:

########
# cns-deploy -g --abort --log-file=/var/log/cns-deploy/latest-cns-deploy-abort-5.log
Using OpenShift CLI.
NAME              STATUS    AGE
storage-project   Active    2d
Using namespace "storage-project".
Do you wish to abort the deployment?
[Y]es, [N]o? [Default: N]: y
service "heketi" deleted
serviceaccount "heketi-service-account" deleted
No resources found
service "heketi-storage-endpoints" deleted
deploymentconfig "heketi" deleted
route "heketi" deleted
template "deploy-heketi" deleted
template "heketi" deleted
Error from server (NotFound): secrets "heketi-db-backup" not found
node "dhcp46-53.lab.eng.blr.redhat.com" labeled
node "dhcp47-145.lab.eng.blr.redhat.com" labeled
node "dhcp47-131.lab.eng.blr.redhat.com" labeled
daemonset "glusterfs" deleted
template "glusterfs" deleted
########

Expected results: No error messages should be seen during the operation


Additional info:

Comment 7 Raghavendra Talur 2017-04-04 13:29:51 UTC
patch posted at https://github.com/gluster/gluster-kubernetes/pull/232

Comment 8 Prasanth 2017-04-12 08:46:40 UTC
Verified as fixed.

Comment 10 errata-xmlrpc 2017-04-20 18:29:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112

Comment 11 vinutha 2018-12-06 19:40:42 UTC
Marking qe-test-coverage as - since the preferred mode of deployment is using ansible


Note You need to log in before you can comment on or make changes to this bug.