Bug 143749 - Anaconda report Bug before starting to copy rpm's
Summary: Anaconda report Bug before starting to copy rpm's
Status: CLOSED DUPLICATE of bug 138419
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-26 19:53 UTC by Christian Rauch
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rauch 2004-12-26 19:53:56 UTC
Description of problem:
FC3 should be installed besides Windows ME.
Anaconda stopps an shows following Bug before starting to copy rpm's
to HDD (after root password selection).


Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 1074, in handleRenderCallback
    self.currentWindow.renderCallback()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/iw/progress_gui.py",
line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py",
line 551, in turnOnFilesystems
    diskset.savePartitions ()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/partedUtils.py",
line 715, in savePartitions
    disk.commit()
error: Bug: Assertion (heads < 256) at disk_dos.c:486 in function
probe_partition_for_geom() failed.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb75138ac>
disk: <PedDisk object at 0xb7540428>


***I can send you the whole bugfile (anacdump.txt), it's to large to
send by this form***



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Start Anaconda to install FC3 by selfbooting CD
2.select German specific configuration
3.HDD formatet manually:
hda1: fat32 (Windows ME on it)
hda2: "/boot" "ext3"
hda3: "VolGroup00" "LVM PV"

for"LVM Datenträgergruppen":
- VolGroup00
- - LogVol01 "    " "swap"
- - LogVol00 "/"    "ext3"


4. slect GRUB as Bootloader
5. added second OS: Windows ME "/dev/hda1", and selected as standart
6. chosed which rpm's to install
7. start installation
  
Actual results:
- Bug is reported (save at Floppy)
- system reboots automatically after klick on "OK"


Expected results:
Anaconda should start to copy the rpm's to HDD until Fedora is installed



Additional info:
If I install FC3 with no OS besides, it works well.

Comment 1 Jeremy Katz 2004-12-27 02:01:16 UTC

*** This bug has been marked as a duplicate of 138419 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:07:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.