Bug 143754 - Guppi gives a segmentation fault when trying to display a report in gnucash
Summary: Guppi gives a segmentation fault when trying to display a report in gnucash
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Guppi (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-26 21:31 UTC by Marcin Draminski
Modified: 2014-03-17 02:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-28 05:51:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of gnucash when crashing (102.21 KB, text/plain)
2004-12-26 21:34 UTC, Marcin Draminski
no flags Details

Description Marcin Draminski 2004-12-26 21:31:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When running gnucash and trying to display a report, Guppi gives a
segmentation fault and crashes together with gnucash.

I'm attaching an strace

Version-Release number of selected component (if applicable):
Guppi-0.40.3-21

How reproducible:
Always

Steps to Reproduce:
1. Open a gnucash report
2.
3.
    

Actual Results:  Guppi gives a segmentation fault. gnucash crashes

Expected Results:  The report should be displayed

Additional info:

Comment 1 Marcin Draminski 2004-12-26 21:34:30 UTC
Created attachment 109129 [details]
strace of gnucash when crashing

Comment 2 Sitsofe Wheeler 2004-12-27 19:15:16 UTC
Could you install Guppi-debuginfo-0.40.3-21.i386.rpm and get a gdb backtrace?

Comment 3 Marcin Draminski 2004-12-27 20:16:10 UTC
I ran gdb, it seems that the problem was with gtk+ not with Guppi

(gdb) continue
Continuing.
Detaching after fork from child process 4876.

Program received signal SIGSEGV, Segmentation fault.
0x048ad68e in gtk_notebook_set_show_border () from /usr/lib/libgtk-1.2.so.0
 
So i reinstalled rpm -ivh --force gtk+-1.2.10-33.i386.rpm

And now is working all right.  I checked before reinstalling gtk+ and several
applications had problems with displaying things or opening more windows.

Thanks a lot for your help.
BR
Marcin


Note You need to log in before you can comment on or make changes to this bug.