Bug 143756 - modprobe acpi kernel oops
modprobe acpi kernel oops
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2004-12-26 18:44 EST by Gustavo A. Lozano
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo A. Lozano 2004-12-26 18:44:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Simple:

[root@Grissom ~]# modprobe acpi
Segmentation Fault

[root@Grissom ~]# dmesg -c
    ACPI-0292: *** Error: Looking up [_PPC] in namespace,
AE_ALREADY_EXISTS
    ACPI-1133: *** Error: [NULL NAME], AE_ALREADY_EXISTS
Unable to handle kernel NULL pointer dereference at virtual address
00000010
 printing eip:
c01dcf23
*pde = 12240001
Oops: 0000 [#1]
SMP
Modules linked in: acpi autofs4 microcode dm_mod button battery ac md5
ipv6 ohci1394 ieee1394 yenta_socket pcmcia_core ohci_hcd ehci_hcd
snd_atiixp_modem snd_atiixp snd_ac97_codec snd_pcm_oss snd_mixer_oss
snd_pcm snd_timer snd soundcore snd_page_alloc 8139too mii ext3 jbd
CPU:    0
EIP:    0060:[<c01dcf23>]    Not tainted VLI
EFLAGS: 00010246   (2.6.9-1.715_FC3smp)
EIP is at acpi_ps_parse_aml+0xb0/0x1a1
eax: 00000000   ebx: dbd1a400   ecx: c02f496e   edx: c02f496e
esi: dbd1a400   edi: dbe5e280   ebp: 00000007   esp: d40c0c38
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 3415, threadinfo=d40c0000 task=c2bca6a0)
Stack: dbf69ec0 00000000 dbd1a400 dbdac440 00000001 c01dbe89 c84db580
c84db580
       c043a6f4 c043a6f4 c01dbea8 dbbb3880 c01d9ec9 dbbb3880 db1fac00
00000000
       c01d3761 dbe38980 d40c0cd8 00000000 00000000 c84db580 db1fac00
00000000
Call Trace:
 [<c01dbe89>] acpi_ns_one_complete_parse+0x69/0x79
 [<c01dbea8>] acpi_ns_parse_table+0xf/0x1f
 [<c01d9ec9>] acpi_ns_load_table+0x69/0x8d
 [<c01d3761>] acpi_ex_add_table+0x6d/0xa6
 [<c01d3a90>] acpi_ex_load_op+0x1a7/0x1ef
 [<c01d861c>] acpi_ex_resolve_node_to_value+0xe4/0x100
 [<c01d4367>] acpi_ex_resolve_to_value+0x37/0x40
 [<c01d6522>] acpi_ex_resolve_operands+0x1c6/0x30c
 [<c01d57cd>] acpi_ex_opcode_1A_1T_0R+0x21/0x4f
 [<c01cf35e>] acpi_ds_exec_end_op+0xa5/0x25b
 [<c01dcbdb>] acpi_ps_parse_loop+0x523/0x7bb
 [<c01dcec0>] acpi_ps_parse_aml+0x4d/0x1a1
 [<c01dd6ef>] acpi_psx_execute+0x13b/0x194
 [<c01dabe2>] acpi_ns_execute_control_method+0x3b/0x47
 [<c01dab90>] acpi_ns_evaluate_by_handle+0x6f/0x86
 [<c01daa9d>] acpi_ns_evaluate_relative+0xa9/0xc3
 [<c01da393>] acpi_evaluate_object+0xf3/0x1a0
 [<c01e754d>] acpi_processor_set_pdc+0x72/0x78
 [<c01e77d3>] acpi_processor_get_performance_info+0x29/0x68
 [<c01e78a2>] acpi_processor_register_performance+0x8e/0xc7
 [<dc9e73b7>] acpi_cpufreq_cpu_init+0x93/0x296 [acpi]
 [<c01427f7>] cache_alloc_refill+0x156/0x19d
 [<c0267882>] cpufreq_add_dev+0x10c/0x2b3
 [<c0115955>] do_flush_tlb_all+0x0/0x59
 [<c01039d2>] send_IPI_allbutself+0x12/0x24
 [<c0115abf>] smp_call_function+0xda/0xe4
 [<c0115955>] do_flush_tlb_all+0x0/0x59
 [<c014db3c>] unmap_area_pmd+0x4e/0x59
 [<c0135bab>] load_module+0x978/0x9fa
 [<c0149cea>] vma_link+0x44/0xbc
 [<dc982000>] acpi_cpufreq_init+0x0/0xa [acpi]
 [<c0212d5b>] sysdev_driver_register+0x7c/0xc0
 [<c026836c>] cpufreq_register_driver+0x75/0xda
 [<c0135d43>] sys_init_module+0x116/0x238
 [<c02c69df>] syscall_call+0x7/0xb
Code: 00 ba 6d 04 00 00 6a 00 b8 3a 3a 2e c0 ff b3 b4 01 00 00 68 86
4e 2e c0 e8 52 de ff ff 83 c4 10 83 fd 07 75 1a 8b 83 b0 01 00 00 <83>
78 10 00 75 0e 80 48 09 08 8b 83 b0 01 00 00 c6 40 1c 01 8b


Version-Release number of selected component (if applicable):
2.6.9-1.715_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.modprobe acpi
2.
3.
    

Actual Results:  nothing

Expected Results:  acpi module loaded

Additional info:

the dmesg part is up
Comment 1 Venkatesh Pallipadi 2004-12-27 20:23:01 EST
What platform is this?

This looks very similar to: http://bugme.osdl.org/show_bug.cgi?id=3147

The bug in 3147 above happens on some BIOSes when:
1) You try to load speedstep-centrino module first, which calls _PDC 
method. It fails beacuse BIOS doesn't support MSR based transition. 
2) Then you try loading ACPI module, which does _PDC again and fails 
with an oops.

And it was root caused to BIOS, which cannot handle multiple writes 
to _PDC.

Can you check whether you have speedstep-centrino being tried before 
acpi. Try disabling speedstep-centrino in your config and check 
whether the failure goes away. That should say whether this BUG is 
same as 3147 above.
Comment 2 Dave Jones 2005-07-15 16:05:23 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Dave Jones 2005-08-04 14:43:40 EDT
Please retest this bug on the latest errata kernel.  (If running SMP, make sure
you upgrade mkinitrd seperately _first_)

Note You need to log in before you can comment on or make changes to this bug.