Bug 1437579 - radosgw-admin: unable to set global quotas in RGWPeriodConfig
Summary: radosgw-admin: unable to set global quotas in RGWPeriodConfig
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Casey Bodley
QA Contact: Tejas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-30 15:12 UTC by Orit Wasserman
Modified: 2017-07-30 15:41 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:31:09 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 19409 None None None 2017-03-30 15:12 UTC

Description Orit Wasserman 2017-03-30 15:12:48 UTC
Description of problem:

with the regionmap commands removed, there's no way for radosgw-admin to modify the quota settings in RGWPeriodConfig

recommending a set of 'radosgw-admin period quota' commands to match the existing 'radosgw-admin quota set/enable/disable'
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 Casey Bodley 2017-04-20 19:58:28 UTC
fix cherry-picked onto ceph-2-rhel-patches

Comment 10 Tejas 2017-05-02 05:52:47 UTC
Verified in ceph version 10.2.7-13.el7cp (4955aa6a90abc27bc043729db19df24e1c840eac)

Verified the "global quota get/set/enable/disable" commands on the primary, and the changes are propogated to the secondary sites.

Thanks,
Tejas

Comment 12 errata-xmlrpc 2017-06-19 13:31:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.