Bug 143775 - incorrect glib2_base_version field in spec file of pango-1.8.0-1
incorrect glib2_base_version field in spec file of pango-1.8.0-1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 09:01 EST by Alan Sanderson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 23:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Sanderson 2004-12-27 09:01:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-AU; rv:1.7.5)
Gecko/20041213 Firefox/1.0

Description of problem:
[root@fc3-p4-2260 SPECS]# rpm -q glib2-devel
glib2-devel-2.4.8-1.fc3

now according to the SPEC file pango-1.8.0 requires glib2-devel 2.4.0
to build, however upon issuing 'rpmbuild -bb --target i686 pango.spec'
the build fails with error;

checking for GLIB - version >= 2.5.7... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file
config.log for the
*** exact error that occured. This usually means GLIB is incorrectly
installed.
configure: error:
*** Glib 2.5.7 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
error: Bad exit status from /var/tmp/rpm-tmp.61176 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.61176 (%build)

In short it looks as though the glib2_base_version field needs to be
updated to 2.5.7

Version-Release number of selected component (if applicable):
panog-1.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb --target i686 pango.spec
2.
3.
    

Actual Results:  build fails

Expected Results:  told by RPM that I should have glib2-devel >= 2.5.7
installed to build

Additional info:
Comment 1 Matthias Clasen 2005-10-27 23:41:48 EDT
Fixed in the next build

Note You need to log in before you can comment on or make changes to this bug.