Bug 143778 - Installer anaconda crash assert heads <256 fails on disk partitioning
Installer anaconda crash assert heads <256 fails on disk partitioning
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 11:03 EST by Mark Carter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file generated during failed install (728.26 KB, text/plain)
2004-12-27 11:05 EST, Mark Carter
no flags Details

  None (edit)
Description Mark Carter 2004-12-27 11:03:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The core 3 installation CDs worked for a 30 GB disk, but seem to fail
with an 80 GB disk.  Errors occur with "ignore" or "continue" as early
as the keyboard select screen.  The final error occurs when disk is
ready to be formatted (no formatting takes place):
File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/partedUtils.py",
line 715, in savePartitions
    disk.commit()
error: Bug: Assertion (heads < 256) at disk_dos.c:486 in function
probe_partition_for_geom() failed.

Full dump attached.

Version-Release number of selected component (if applicable):
Core 3 standard

How reproducible:
Always

Steps to Reproduce:
1.Attempt to install on hdb 80 GB disk
2.
3.
    

Actual Results:  Install fails

Expected Results:  Installation of FC3

Additional info:

Dump attached.
Comment 1 Mark Carter 2004-12-27 11:05:59 EST
Created attachment 109139 [details]
dump file generated during failed install
Comment 2 Jeremy Katz 2004-12-27 13:27:09 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.