Bug 1437793 - rolekit rolectl cmd RC=256 on ppc64
Summary: rolekit rolectl cmd RC=256 on ppc64
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pki-core
Version: 28
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Heimes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-03-31 08:29 UTC by Michel Normand
Modified: 2019-02-27 15:46 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-27 09:13:17 UTC


Attachments (Terms of Use)
/var/log/rolekit (326.91 KB, text/plain)
2017-03-31 08:29 UTC, Michel Normand
no flags Details
tarball of many captured logs (contains previous rolekit log) (1.29 MB, application/octet-stream)
2017-03-31 08:32 UTC, Michel Normand
no flags Details

Description Michel Normand 2017-03-31 08:29:34 UTC
Created attachment 1267768 [details]
/var/log/rolekit

rolekit rolectl cmd RC=256 on ppc64 (BE) no error for ppc64le (LE)

Problem while running the fedora openQA server_role_deploy_domain_controller test on a PowerPC host with F26-Alpha

=== extract of openQA issued command:
echo '{"admin_password":"monkeys123","dns_forwarders":{"ipv4":["9.101.4.100"],"ipv6":["9.101.4.100"]}}' | rolectl deploy domaincontroller --name=domain.local --settings-stdin
Deployment can take a long time. To monitor the progress, run
journalctl -ef -u rolekit
Error: COMMAND_FAILED: 256
=== extract  /var/log/rolekit
2017-03-31 03:09:12 ERROR: b'ipa.ipapython.install.cli.install_tool(Server): DEBUG    The ipa-server-install command failed, exception: RuntimeError: CA configuration failed.'
2017-03-31 03:09:12 ERROR: b'ipa.ipapython.install.cli.install_tool(Server): ERROR    CA configuration failed.'
2017-03-31 03:09:12 ERROR: b'ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information'
2017-03-31 03:09:12 ERROR: RolekitError: COMMAND_FAILED: 256
===

Comment 1 Michel Normand 2017-03-31 08:32 UTC
Created attachment 1267769 [details]
tarball of many captured logs (contains previous rolekit log)

Comment 2 Stephen Gallagher 2017-04-03 17:52:14 UTC
The relevant part of the logs:

2017-03-31 03:09:11 ERROR: b'ipa         : DEBUG    Starting external process'
2017-03-31 03:09:11 ERROR: b'ipa         : DEBUG    args=/usr/sbin/pkispawn -s CA -f /tmp/tmpJY6QXA'
2017-03-31 03:09:12 ERROR: b'ipa         : DEBUG    Process finished, return code=1'
2017-03-31 03:09:12 ERROR: b'ipa         : DEBUG    stdout='
2017-03-31 03:09:12 ERROR: b'ipa         : DEBUG    stderr=There was a problem importing one of the required Python modules. The'
2017-03-31 03:09:12 ERROR: b'error was:'
2017-03-31 03:09:12 ERROR: b''
2017-03-31 03:09:12 ERROR: b'    No module named _qpol'
2017-03-31 03:09:12 ERROR: b''
2017-03-31 03:09:12 ERROR: b''
2017-03-31 03:09:12 ERROR: b"ipa.ipaserver.install.cainstance.CAInstance: CRITICAL Failed to configure CA instance: Command '/usr/sbin/pkispawn -s CA -f /tmp/tmpJY6QXA' returned non-zero exit status 1"
2017-03-31 03:09:12 ERROR: b'ipa.ipaserver.install.cainstance.CAInstance: CRITICAL See the installation logs and the following files/directories for more information:'
2017-03-31 03:09:12 ERROR: b'ipa.ipaserver.install.cainstance.CAInstance: CRITICAL   /var/log/pki/pki-tomcat'
2017-03-31 03:09:12 ERROR: b'ipa         : DEBUG    Traceback (most recent call last):'
2017-03-31 03:09:12 ERROR: b'  File "/usr/lib/python2.7/site-packages/ipaserver/install/service.py", line 449, in start_creation'
2017-03-31 03:09:12 ERROR: b'    run_step(full_msg, method)'
2017-03-31 03:09:12 ERROR: b'  File "/usr/lib/python2.7/site-packages/ipaserver/install/service.py", line 439, in run_step'
2017-03-31 03:09:12 ERROR: b'    method()'
2017-03-31 03:09:12 ERROR: b'  File "/usr/lib/python2.7/site-packages/ipaserver/install/cainstance.py", line 591, in __spawn_instance'
2017-03-31 03:09:12 ERROR: b'    DogtagInstance.spawn_instance(self, cfg_file)'
2017-03-31 03:09:12 ERROR: b'  File "/usr/lib/python2.7/site-packages/ipaserver/install/dogtaginstance.py", line 181, in spawn_instance'
2017-03-31 03:09:12 ERROR: b'    self.handle_setup_error(e)'
2017-03-31 03:09:12 ERROR: b'  File "/usr/lib/python2.7/site-packages/ipaserver/install/dogtaginstance.py", line 420, in handle_setup_error'
2017-03-31 03:09:12 ERROR: b'    raise RuntimeError("%s configuration failed." % self.subsystem)'
2017-03-31 03:09:12 ERROR: b'RuntimeError: CA configuration failed.'
2017-03-31 03:09:12 ERROR: b''
2017-03-31 03:09:12 ERROR: b'ipa         : DEBUG      [error] RuntimeError: CA configuration failed.'



Looks like the bug belongs to the Dogtag component. Reassigning.

Comment 4 Matthew Harmsen 2017-11-15 16:06:33 UTC
Ade and Fraser want to know... what the heck is this ticket about?

Comment 5 Fedora End Of Life 2018-05-03 08:38:19 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 6 Christian Heimes 2019-02-27 09:13:17 UTC
I'm closing the BZ as works for me. There hasn't been a test failure caused by rolectl in any recent releases of Fedora.

Comment 7 Stephen Gallagher 2019-02-27 15:46:40 UTC
rolekit was removed from Fedora since Fedora 29.


Note You need to log in before you can comment on or make changes to this bug.