Bug 143785 - hal daemon hangs when repeatedly plugging/unplugging Olympus D535 USB camera
hal daemon hangs when repeatedly plugging/unplugging Olympus D535 USB camera
Status: CLOSED DUPLICATE of bug 136255
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 17:02 EST by Colin Leavett-Brown
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Leavett-Brown 2004-12-27 17:02:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When trying to download pictures from a new Olympus D535 camera, the
first time the camera was plugged in, camera was mounted as a USB
memory stick, the gthumb dialog "would you like to import photos"
correctly started, and we were able to download the photos. Unmounted
the /media/usbdisk, took some more pics, tried to download new pics,
but when plugging in the camera, it did not mount, and we did not get
the "import" dialog. Could not kill the "hald" (would not die);
rebooted the machine, killed the hald, and started "/usr/sbin/hald
--verbose=yes --daemon=no 2>/tmp/haldaemon.log", plugged camera in, it
worked!, unplugged, waited a few seconds, plugged camera in, did not
work, unplugged camera, no further activitiy on /tmp/haldaemon.log,
tried killing hald, would not kill.  

Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
Always

Steps to Reproduce:
1. Start/Restart Hald.
2. Plug in Olympus D535.
3. Unplug Olympus D535.
4. Plug in Olympus D535.
5. Hal is toast!
    

Actual Results:  hal no longer produced any "verbose" output and could
not be killed with "kill nnnn" or "kill -9 nnnn", and would not
detect/process subsequent "hotplug" events.

Expected Results:  Should be able to plug device and see the mount,
then unplug and see the unmount, repeatedly.

Additional info:

How do I attach the log I have?
Comment 1 Colin Leavett-Brown 2004-12-27 17:10:22 EST
Emailed davidz@redhat.com directly to send log as attachment.
Comment 2 David Zeuthen 2005-01-03 14:07:05 EST

*** This bug has been marked as a duplicate of 136255 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.