Bug 143797 - documentation bugs in RHN Satellite Server 3.6 Installation Guide
documentation bugs in RHN Satellite Server 3.6 Installation Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Clay Murphy
Vlady Zlatkin
: Documentation
Depends On:
Blocks: 144404
  Show dependency treegraph
 
Reported: 2004-12-28 05:43 EST by Kurt Keller
Modified: 2009-08-19 23:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 12:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Keller 2004-12-28 05:43:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
- chapter 2.1:
  is:
   ...an Everything install, RedHat this installs packages that if not
properly managed could pose ...
  should be:
   ...an Everything install, this installs packages that, if not
properly managed, could pose...

- chapter 2.1:
  At least for me it was unclear whether the mentioned perl packages
  needed to be manually installed only with the CD/ISO installation
  or also with the kickstart installation (not needed with kickstart,
  as I found out)

- chapter 4.2, point 12 / figure 4-6:
  the text says:
  ...Note that references to protocol such as http:// or https://
should not be included in the HTTP proxy server field...
  the figure says:
  ...The http proxy should be of the form: http://hostname:port,...

  The text is correct, the picture is actually what is being
  displayed during the installation. To avoid confusion, the text
  displayed during installation should be changed, but meanwhile
  it might be easier to add an additional  note in the installation
  docs that the text displayed during installation is wrong and the
  installation docs are correct.

- chapter 8.10, last sentence:
  is:
  ...began...
  should be:
  ...begin...

Version-Release number of selected component (if applicable):
RHNsatellite(EN)-3.6-RHI (2004-12-07T20:06)

How reproducible:
Always

Steps to Reproduce:
I can reproduce the same errors every time I print the guide, as I
don't have a printer with built-in auto-correction module...<g>

Additional info:
Comment 1 Clay Murphy 2005-01-04 13:53:28 EST
These are nice catches, Kurt. Regarding those perl packages mentioned
in section 2.1, those need to be specified individually only when
installing via kickstart. When installing via CD/ISO, selecting the
listed package groups will ensure those packages are included. I'll
attempt to clarify that text.

It seems, however, that you found those packages *did not* need to be
specified during kickstart. If that's the case, please provide
additional details (your steps, the KS config file, etc.) and I'll
ensure engineering is aware of the issue.

The rest of your comments will be addressed in the next release of the
guide. Thanks for your thorough review and detailed feedback.
Comment 2 Clay Murphy 2005-01-04 14:01:20 EST
Robin, I'm bumping this over to you because the item begining '-
chapter 4.2, point 12 / figure 4-6:' actually points to a flaw in the
installer text. It seems all we need to do is remove 'http://' from
the line 'The http proxy should be of the form:
http://hostname:port...' in the RHN Configuration page.

This format will match the documentation and previous sat install
practices. If I need to open a separate bug for this, please let me
know. Otherwise, bounce this back to me when you're done and I'll
finish the remaining documentation changes. Thanks.
Comment 3 Kurt Keller 2005-01-05 02:15:29 EST
Clay, concerning section 2.1, I _think_ that the additional perl
modules (perl-CGI, perl-libwww-perl, ...) must be installed manually
on a CD/ISO installation but not on a kickstart installation. I
fed my machine with a CD and a kickstart file on floppy which
included the following section:

# --------------------------------------------------------------------
# packages to install
%packages --resolvedeps

# package clusters as per RHN Satellite Server v3.6 Installation Guide
@ Base
@ Server
@ Development Tools
@ Legacy Software Development

# additional packages as per RHN Satellite Server v3.6 Installation Guide
perl-CGI
perl-Time-HiRes

# packages we want
ntp
screen
vlock
sysstat
rcs
# --------------------------------------------------------------------

Checking after the installation, the mentioned perl modules were
all there.

I was referring to the list
perl-CGI perl-libwww-perl ... perl-XML-Encoding.
Maybe you are talking about the perl-CGI and perl-TimeHiRes packages
or groups which go in the kickstart file?
Comment 4 Clay Murphy 2005-01-05 17:28:39 EST
Ahh, my apologies for the confusion, Kurt. You are correct in that
those perl packages must be manually installed (via up2date, for
instance) only when installing from CD/ISO. As you found, specifying
the recommended packages (perl-CGI, perl-Time-HiRes) at kickstart
eliminates that manual step.

Although this is what I intended to convey when I drafted the section
immediately following the CD/ISO package group list - "Then after
operating system installation, register the system..." - it is clear
to me now I did not tie this step to CD/ISO installs.

So the resolution to that particular item is for me to make that
correlation, perhaps by beginning that sentence with, "If you
installed the operating system by CD or ISO (rather than kickstart),
you will need to register the system..."

Again, many thanks for your input.
Comment 5 Robin Norwood 2005-01-06 16:32:31 EST
The description text on the installer page has been fixed in CVS, and
should be available in the next version of the satellite.
Comment 6 Robin Norwood 2005-02-28 09:59:02 EST
Test plan:

1) perform a satellite install, up until the 'configure.pxt' page.
- Verify that the text description at the top of the page is accurate and makes
sense.
Comment 7 Vlady Zlatkin 2005-03-01 18:36:59 EST
software reqs part of the docs complete
screenshot of sat-installer in docs FAILS

the actual satellite installer bug was addressed here: bug #144404
Comment 8 Robin Norwood 2005-03-01 20:56:50 EST
As vlady points out, by mixing my fixes in with this docs bug, I've created a
confusing mess.  I've created bug #150062 to describe my fix.  Ignore all my
comments on this bug and go there instead.

Re-assigning to cmurphy, because vlady indicates that his work for this bug is
not yet complete.
Comment 9 Clay Murphy 2005-03-02 18:11:22 EST
The screenshot of the new sat install page is a separate documentation
change, so it will need a separate bug. If someone can launch a sat
install and grab it for me, great. Otherwise, file a new bug against
RHN 400.

Setting this back to ON_DEV.
Comment 10 Clay Murphy 2005-03-04 15:52:31 EST
Shifting my ON_DEV bugs to ON_QA to reflect today's push.
Comment 11 Vlady Zlatkin 2005-03-10 19:07:39 EST
shughes will get you a screenshot tomorrow morning
Comment 12 Clay Murphy 2005-03-11 17:08:08 EST
The new screenshot has been added to the docs and will be in Monday's
QA push - thanks Vlad!
Comment 13 Vlady Zlatkin 2005-03-15 15:18:03 EST
man, my screenshot looks good!!
Comment 14 Todd Warner 2005-04-08 12:19:44 EDT
mass move: PROD_READY --> CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.