Bug 1438005 - ppc64le host deploy fails: Failed to execute stage 'Package installation': Package collectd-disk cannot be found.
Summary: ppc64le host deploy fails: Failed to execute stage 'Package installation': Pa...
Keywords:
Status: CLOSED DUPLICATE of bug 1443508
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: General
Version: 1.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.1.2
: ---
Assignee: Yedidyah Bar David
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-31 15:26 UTC by Evgheni Dereveanchin
Modified: 2017-04-25 12:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-25 12:57:50 UTC
oVirt Team: Integration
ylavi: ovirt-4.1+
ylavi: Triaged+


Attachments (Terms of Use)

Description Evgheni Dereveanchin 2017-03-31 15:26:47 UTC
Description of problem:
Adding POWER8 hosts to 4.1 Engine via the WebUI fails since collectd-disk cannot be found

Version-Release number of selected component (if applicable):
otopi.context context.dumpEnvironment:770 ENV INFO/PACKAGE_VERSION=str:'1.6.0'

How reproducible:
Always

Steps to Reproduce:
1. install a CentOS 7.3 ppc64le host
2. install ovirt-release41 RPM
3. create PPC cluster in oVirt 4.1 if missing
4. add a new host to the PPC cluster, leave all defaults

Actual results:
Setup fails with error:
Failed to install Host host1. Failed to execute stage 'Package installation': Package collectd-disk cannot be found.

Expected results:
host deployed successfully

Additional info:

# yum search collectd-disk
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: linux.mirrors.es.net
 * ovirt-4.1: resources.ovirt.org
 * ovirt-4.1-epel: linux.mirrors.es.net
Warning: No matches found for: collectd-disk
No matches found

Comment 2 Evgheni Dereveanchin 2017-03-31 16:37:07 UTC
Out of curiosity I generated an RPM using fakeprovide to see if this is the only package missing but there seems to be more, such as:
collectd-write_http [1]
fluentd [2]

After generating and installing a few more fakes I was able to get the host added.

Can these be made optional and not fail the install?

[1] https://github.com/oVirt/ovirt-host-deploy/blob/b97a668c903564edc9b03d3fe5e2d38bf53aaff7/src/plugins/ovirt-host-deploy/collectd/packages.py#L49-L53
[2] https://github.com/oVirt/ovirt-host-deploy/blob/b97a668c903564edc9b03d3fe5e2d38bf53aaff7/src/plugins/ovirt-host-deploy/fluentd/packages.py#L49-L51

Comment 3 Yedidyah Bar David 2017-04-25 12:57:50 UTC
This will be fixed for now by not failing deploy on the missing packages.

*** This bug has been marked as a duplicate of bug 1443508 ***


Note You need to log in before you can comment on or make changes to this bug.