Bug 143805 - Image shifts right at random times in X programs
Image shifts right at random times in X programs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-28 08:43 EST by Arnold Robbins
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnold Robbins 2004-12-28 08:43:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I use w9wm, a modified version of 9wm as my window manager.
At random tmes in xterm, gvim and mozilla, the image will move
to the right, outside of the window boundary, leaving weird
extra pixels on the root window or on windows underneath the one
that experiences the shift.

The gvim was compiled on FC1, but xterm and mozilla are from FC3.
I also saw it with an old version of the gv postscript viewer
compiled under FC1.

It is frustrating as it's random and doesn't always happen.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Mike A. Harris 2005-01-31 20:54:14 EST
This is a window manager issue that should be reported to the
developers of the window manager you're using.  After they
investigate the issue, if they determine that there is a real
X server bug or video driver bug present, then you (or they)
can report the bug to X.Org bugzilla at http://bugs.freedesktop.org

Setting status to "NOTABUG" as this is most probably a bug in the
window manager, and does not appear to be an X.Org or Red Hat
specific issue.
Comment 2 Arnold Robbins 2005-02-01 01:20:00 EST
This is NOT a window manager issue. I use the same window manager
under FC2 on my Virge S3 laptop and have *never* seen it. It's a
video driver issue.  The *same* w.m. worked perfectly using FC1. The
problem shows up occasionally under FC2 and frequently under FC3.
The w.m. is slightly modified version of w9wm, you can get it from
ftp://ftp.freefriends.org/arnold/upload/w9wm-0.5.0.tar.gz. The code
has not changed since July 2002. I will add a separate comment when
I get to my office with the exact model of my video card.  It is most
definitely a video driver problem though. I only mentioned the w.m.
to help in reproducing the problem.
Comment 3 Mike A. Harris 2005-02-01 02:04:06 EST
If you believe this to be a video driver issue, please report
a bug in X.org bugzilla at http://bugs.freedesktop.org in the
"xorg" component, so the video driver maintainer for whatever
video hardware you're using (you didn't mention this anywhere
above) can investigate the issue.

Once you have filed your bug report in the X.Org bugzilla, if
you paste the X.Org bug URL here, Red Hat will track the issue
in the X.Org bugzilla, and will review any fixes that become
available for consideration in future Fedora Core updates.

Thanks in advance.
Comment 4 Mike A. Harris 2005-02-01 02:05:08 EST
Setting status to "NEEDINFO" and awaiting upstream bug report
URL for tracking.
Comment 5 Arnold Robbins 2005-02-01 05:21:55 EST
OK, will do. The card is a GeForce 2 mx "Tornado", 64M video ram.
I have also seen the problem under GNOME.  Sorry for the poor quality
of my initial bug report.  Thanks!
Comment 6 Mike A. Harris 2005-02-01 05:24:25 EST
Setting status back to "NEEDINFO" and awaiting upstream bug
report URL for tracking.

Comment 7 Mike A. Harris 2005-04-15 10:33:30 EDT
This bug has not been updated to provide us with the upstream
bug URL requested above. Please report the issue to X.Org bugzilla at
http://bugs.freedestop.org in the "xorg" component.

Setting status to "NOTABUG" due to lack of information.

Note You need to log in before you can comment on or make changes to this bug.