Bug 143808 - couple of minor problems
couple of minor problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: s390utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-28 09:49 EST by David Binderman
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 10:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-12-28 09:49:12 EST
Description of problem:

I just tried to compile package s390utils-1.3.2-3 from 
Redhat Fedora development tree.

The compiler said

1.

xcec-bridge.c(444): warning #187: use of "=" where "==" may have been
intended

The source code is

	if ( (errno=EMSGSIZE) && (!i_s_item->mtu_warning) ) {

Deeply suspicious code. Suggest 

	if ( (errno == EMSGSIZE) && (!i_s_item->mtu_warning) ) {

is better code.

2.

cmsfsvol.c(55): warning #269: invalid format string conversion

The source code is

    (void) printf("LABEL  VDEV M  STAT   CYL TYPE \
BLKSZ   FILES  BLKS USED-(%) BLKS LEFT  BLK TOTAL\n");

%) isn't a valid specifier for printf. Suggest use %% for %.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phil Knirsch 2005-09-06 10:58:41 EDT
Fixed in latest development version.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.