Bug 1438086 - polkit is aborting
Summary: polkit is aborting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: polkit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1439263 1439266 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-31 20:56 UTC by darrell pfeifer
Modified: 2017-04-07 18:17 UTC (History)
15 users (show)

Fixed In Version: polkit-0.113-11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-04 23:32:19 UTC
Type: Bug


Attachments (Terms of Use)

Description darrell pfeifer 2017-03-31 20:56:59 UTC
Description of problem:

Mar 31 13:07:52 localhost.localdomain systemd[1]: polkit.service: Main process exited, code=killed, status=6/ABRT
Mar 31 13:07:52 localhost.localdomain systemd[1]: Failed to start Authorization Manager.
Mar 31 13:07:52 localhost.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r
Mar 31 13:07:52 localhost.localdomain systemd[1]: polkit.service: Unit entered failed state.
Mar 31 13:07:52 localhost.localdomain systemd[1]: polkit.service: Failed with result 'signal'.


Version-Release number of selected component (if applicable):

0.113-9.fc27

Additional info:

Systemd keeps trying to restart it.

Graphic logins slow to a crawl (using SDDM)

kde starts but without the task manager ribbon.
gnome fails to start at all from SDDM

Restoring 0.113-7.fc26 fixes the problems.

Comment 1 Kevin Fenzi 2017-03-31 23:35:59 UTC
Seeing this here too. 

Mine additionally has a line about a missing init.js: 

Mar 31 15:42:44 sheelba.scrye.com systemd[1]: Starting Authorization Manager...
Mar 31 15:42:44 sheelba.scrye.com polkitd[3157]: Started polkitd version 0.113
Mar 31 15:42:44 sheelba.scrye.com polkitd[3157]: <no filename>:0: can't open init.js: No such file or directory
Mar 31 15:42:44 sheelba.scrye.com systemd[1]: polkit.service: Main process exited, code=killed, status=6/ABRT
Mar 31 15:42:44 sheelba.scrye.com systemd[1]: Failed to start Authorization Manager.
Mar 31 15:42:44 sheelba.scrye.com systemd[1]: polkit.service: Unit entered failed state.
Mar 31 15:42:44 sheelba.scrye.com systemd[1]: polkit.service: Failed with result 'signal'.

Comment 2 Jan Pokorný [poki] 2017-04-03 13:22:37 UTC
That's what seems to cause a lot of other troubles:

$ reboot
> Failed to set wall message, ignoring: Method call timed out
> Failed to reboot system via logind: Method call timed out
> Failed to open /dev/initctl: Permission denied
> Failed to talk to init daemon.

Comment 3 Miloslav Trmač 2017-04-03 14:43:39 UTC
Peter Robinson, this seems to be caused by your update. Please fix it or revert.

Comment 4 Peter Robinson 2017-04-03 14:53:45 UTC
it's already on my list to review today

Comment 5 Bruno Wolff III 2017-04-04 09:56:16 UTC
The problem is also happening with lightdm, which I use with XFCE on one machine instead of sddm.

Comment 6 Pavlo Rudyi 2017-04-04 12:24:16 UTC
The same problem. First two boots from 0.113-9; the last - 0.113-7:

-- Logs begin at Mon 2016-11-14 12:07:11 EET, end at Tue 2017-04-04 15:01:05 EEST. --
Nov 14 12:07:21 localhost.localdomain systemd[1]: Starting Authorization Manager...
Nov 14 12:07:21 localhost.localdomain polkitd[775]: Started polkitd version 0.113
Nov 14 12:07:21 localhost.localdomain polkitd[775]: Loading rules from directory /etc/polkit-1/rules.d
Nov 14 12:07:21 localhost.localdomain polkitd[775]: Loading rules from directory /usr/share/polkit-1/rules.d
Nov 14 12:07:21 localhost.localdomain polkitd[775]: Finished loading, compiling and executing 9 rules
Nov 14 12:07:21 localhost.localdomain systemd[1]: Started Authorization Manager.
Nov 14 12:07:21 localhost.localdomain polkitd[775]: Acquired the name org.freedesktop.PolicyKit1 on the system bus
Nov 14 12:07:26 localhost.localdomain polkitd[775]: Registered Authentication Agent for unix-session:c1 (system bus name :1.24 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 14 12:07:53 localhost.localdomain polkitd[775]: Registered Authentication Agent for unix-session:2 (system bus name :1.42 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 14 12:44:54 localhost.localdomain polkitd[775]: Unregistered Authentication Agent for unix-session:c1 (system bus name :1.24, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 14 12:44:54 localhost.localdomain polkitd[775]: Unregistered Authentication Agent for unix-session:2 (system bus name :1.42, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 14 12:44:58 localhost.localdomain systemd[1]: Stopping Authorization Manager...
Nov 14 12:44:58 localhost.localdomain systemd[1]: Stopped Authorization Manager.
-- Reboot --
Nov 14 12:45:19 localhost.localdomain systemd[1]: Starting Authorization Manager...
Nov 14 12:45:19 localhost.localdomain polkitd[702]: Started polkitd version 0.113
Nov 14 12:45:19 localhost.localdomain polkitd[702]: Loading rules from directory /etc/polkit-1/rules.d
Nov 14 12:45:19 localhost.localdomain polkitd[702]: Loading rules from directory /usr/share/polkit-1/rules.d
Nov 14 12:45:19 localhost.localdomain polkitd[702]: Finished loading, compiling and executing 9 rules
Nov 14 12:45:19 localhost.localdomain systemd[1]: Started Authorization Manager.
Nov 14 12:45:19 localhost.localdomain polkitd[702]: Acquired the name org.freedesktop.PolicyKit1 on the system bus
Nov 14 12:45:24 localhost.localdomain polkitd[702]: Registered Authentication Agent for unix-session:c1 (system bus name :1.24 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 14 12:45:51 localhost.localdomain polkitd[702]: Registered Authentication Agent for unix-session:2 (system bus name :1.46 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 14 18:15:45 localhost.localdomain polkitd[702]: Unregistered Authentication Agent for unix-session:2 (system bus name :1.46, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 14 18:15:46 localhost.localdomain polkitd[702]: Registered Authentication Agent for unix-session:2 (system bus name :1.140 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 14 20:03:57 localhost.localdomain polkitd[702]: Unregistered Authentication Agent for unix-session:c1 (system bus name :1.24, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 14 20:03:57 localhost.localdomain polkitd[702]: Unregistered Authentication Agent for unix-session:2 (system bus name :1.140, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 14 20:03:59 localhost.localdomain systemd[1]: Stopping Authorization Manager...
Nov 14 20:03:59 localhost.localdomain systemd[1]: Stopped Authorization Manager.
-- Reboot --
Apr 04 14:53:34 localhost.localdomain systemd[1]: Starting Authorization Manager...
Apr 04 14:53:34 localhost.localdomain polkitd[683]: Started polkitd version 0.113
Apr 04 14:53:34 localhost.localdomain polkitd[683]: Loading rules from directory /etc/polkit-1/rules.d
Apr 04 14:53:34 localhost.localdomain polkitd[683]: Loading rules from directory /usr/share/polkit-1/rules.d
Apr 04 14:53:34 localhost.localdomain polkitd[683]: Finished loading, compiling and executing 11 rules
Apr 04 14:53:34 localhost.localdomain systemd[1]: Started Authorization Manager.
Apr 04 14:53:34 localhost.localdomain polkitd[683]: Acquired the name org.freedesktop.PolicyKit1 on the system bus
Apr 04 14:53:38 localhost.localdomain polkitd[683]: Registered Authentication Agent for unix-session:c1 (system bus name :1.22 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Apr 04 14:53:46 localhost.localdomain polkitd[683]: Registered Authentication Agent for unix-session:2 (system bus name :1.40 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8)

Comment 7 Jeremy Linton 2017-04-04 19:21:50 UTC
This was me... 

In the move to mozjs24 I converted it from using a statically built-in init.js file to one loaded from the filesystem (which wasn't being shipped). I have updated the patch to revert to using a built in one.

Comment 8 Peter Robinson 2017-04-04 19:26:12 UTC
This is now building as polkit-0.113-10.git2919920.fc27 please test and update.

Comment 9 Jeremy Linton 2017-04-04 19:52:25 UTC
Oh, I mistyped the patch moves polkit from mozjs24 to mozjs38.

Comment 10 Miloslav Trmač 2017-04-04 20:28:57 UTC
polkit-0.113-11 is equivalent to -7, and should work as well, or as badly, as -7.

Comment 11 darrell pfeifer 2017-04-04 23:32:19 UTC
Verified, fixed in 0.113-12

Comment 12 Valdis Kletnieks 2017-04-05 03:34:56 UTC
(In reply to Peter Robinson from comment #8)
> This is now building as polkit-0.113-10.git2919920.fc27 please test and
> update.

Snarfed that from koji, confirming works fine on my laptop.

Comment 13 Miloslav Trmač 2017-04-05 14:40:13 UTC
*** Bug 1439266 has been marked as a duplicate of this bug. ***

Comment 14 Miloslav Trmač 2017-04-07 18:17:26 UTC
*** Bug 1439263 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.