Bug 143810 - Konqueror cannot mount CDROM/DVDROM
Konqueror cannot mount CDROM/DVDROM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-28 10:00 EST by Granville Xiong
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 13:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Granville Xiong 2004-12-28 10:00:05 EST
Description of problem:

Konqueror cannot mount a normal CDROM or DVDROM. After clicking the
"Devices" in the "Servies" inside konqueror as a normal user account,
an error message box popped up saying that:

mount: block device /dev/hdb is write-protected, mounting read-only
mount: /dev/hdb already mounted or /media/cdrom busy
Please check that the disk is entered correctly.

Also after failed to mount, when I tried to eject the CDROM, no matter
through konqueror or command line, an error message says:

Eject /dev/hdb failed!

Interestingly, after waiting for a while in which all konqueror
processes disappeared shown by the "ps" command, I can use command
line "eject" to open the CDROM/DVDROM drive. After inserting the
CDROM/DVDROM back, I can use command line "mount /media/cdrom" and
"umount /media/cdrom" and "eject /media/cdrom" without any problems.
Also the gnome program "nautilus" does not have this problem: it can
mount, umount and eject CDROM/DVDROM correctly.

Version-Release number of selected component (if applicable):

kdebase-3.3.1-4.3.FC3


How reproducible:

Always


Steps to Reproduce:
1. Insert a CDROM/DVDROM.
2. Start konqueror.
3. Click the devices list in the services panel on the left and click
CDROM.
  
Actual results:

konqueror cannot mount CDROM/DVDROM.

Expected results:

konqueror should be able to mount, umount and eject CDROM/DVDROM
without any problems.

Additional info:
Comment 1 Jeffrey Silverman 2005-03-08 13:43:12 EST
This sounds like a duplicate of bug 142637.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142637

Fix? Update gamin to 0.0.25
Comment 2 David Houlder 2005-07-08 02:02:49 EDT
This happens to me too, and I'm running gamin-0.1.1-1.FC3.
Just did a yum update and reboot this morning (8 July 2005).

Here's what happens for me (FC3 on Dell P370)
1. Insert ordinary iso9660 cdrom into drive.
2. Click the CD icon on the desktop
3. konqueror opens up, shows the "mounting" dialog and a progress bar for a few
seconds, then I get an error dialog saying this...

mount: block device /dev/hda is write-protected, mounting read-only
mount: /dev/hda already mounted or /media/cdrecorder busy
Please check that the disk is entered correctly.
... and no mount occurs.

4.
[djh900@dh ~]$ fuser /dev/cdwriter
/dev/cdwriter:        4702
[djh900@dh ~]$ ps -fp 4702
UID        PID  PPID  C STIME TTY          TIME CMD
djh900    4702  4275  0 15:32 ?        00:00:00 kdeinit: kio_audiocd audiocd
/tmp/ksocket-djh900/klauncherOHVY

5. Wait a little bit (a minute or two) and kio_audiocd will eventually exit.

6. After that, in the (still open) konqueror window entitled file:/media/cdrecorder
you can click on the CD-ROM node under "Devices" in the left hand column and it
will mount the CD just fine.

So, I'm guessing kio_audiocd gets first stab at /dev/cdwriter, and isn't exiting
before konqueror tries the mount.

A little probing with strace and lsof on kio_audiocd reveals...
[djh900@dh ~]$ lsof -p 4819
COMMAND  PID   USER   FD   TYPE     DEVICE     SIZE    NODE NAME
....
kdeinit 4819 djh900    9u  unix 0xe485e500            40528 socket
kdeinit 4819 djh900   10u  unix 0xe6bf8b80            40530 socket
kdeinit 4819 djh900   11r   REG      253,0  1283719 3655639
/var/tmp/kdecache-djh900/ksycoca
kdeinit 4819 djh900   12u   BLK        3,0             1107 /dev/hda
[djh900@dh ~]$ strace -p 4819
Process 4819 attached - interrupt to quit
select(11, [10], NULL, NULL, NULL <unfinished ...>
Process 4819 detached

... so it looks like it's waiting on ssome unix socket.

Any thoughts?
Thanks
Comment 3 Ngo Than 2005-08-23 13:57:45 EDT
yes, it's a bug in the kdemultimedia package and is now fixed in the
kdemultimedia-3.4.2-0.fc3.2. I will do FC4 update soon. 

Many thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.