Bug 143813 - Mouse not working after install
Mouse not working after install
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-12-28 12:18 EST by euphgeek
Modified: 2015-01-04 17:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-29 20:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
my xorg.conf file (3.68 KB, text/plain)
2004-12-28 12:22 EST, euphgeek
no flags Details
output from dmesg (15.21 KB, text/plain)
2004-12-28 12:24 EST, euphgeek
no flags Details

  None (edit)
Description euphgeek 2004-12-28 12:18:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
I installed Fedora Core 3 using noprobe, because it wouldn't work any
other way.  While booting up, it freezes at "finding new hardware", so
I have to enter interactive mode and disable starting kudzu so that
the system will start.  When I do boot into the system, I find that my
USB mouse (Microsoft Explorer Optical) doesn't work.  I can't move the
pointer at all.  This was an upgrade from Fedora Core 2, and the
xorg.conf file I used successfully in FC2 remained unchanged.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Fedora Core 3
2. Boot

Actual Results:  Cannot use mouse to move pointer

Expected Results:  Should be able to use mouse

Additional info:
Comment 1 euphgeek 2004-12-28 12:22:11 EST
Created attachment 109153 [details]
my xorg.conf file
Comment 2 euphgeek 2004-12-28 12:24:22 EST
Created attachment 109154 [details]
output from dmesg
Comment 3 euphgeek 2004-12-29 21:27:07 EST
The kernel version I'm using is 2.6.9-1.681_FC3
Comment 4 euphgeek 2004-12-29 21:29:34 EST
I got the same results with 2.6.9-1.667
Comment 5 zimon 2005-03-03 11:02:22 EST
Same problem was here when installing Fedora Core 3 (fc3) from scratch
(so no update).

After installation, in the first boot, the system went to kudzu (?)
and wanted the finalize the installation, asking date+time, monitor
type and such. The system was very difficult to handle then, because
there was no working mouse and some windows didn't have any keyboard
shortcuts to go futher or the shortcuts didn't somehow work. 

For example in a stage, "Please select resolution" nothing worked.
Finally I remembered Ctrl+Shift+NumLock trick to enable keyboard's
numpad's mouse emulation in X. 

I believe it expected to find PS/2 mouse, as there is such a port in
the machine, but there is no PS2-mouse though. The machine has/had
3-button serial MouseSystems mouse and also Bluetooth HID mouse and
Bluetooth dongle. But those mouses were not recognized although they
both worked well in fc1 and fc2 and also in fc3 the HID Bluetooth
mouse was "easily" configured manually later when the first boot was

So, I think there should be some mouse test in the start of Kudzu
before anytyhing else, and also note that if mouse doesn't work, one
can use Ctrl+Shift+Numlock trick to emulate mouse.

For me this problem was easy to go around, but I'd think many who are
installing Linux distribution for the first time couldn't have gone
through the first boot in any other way but disabling kudzu with
'I'nteractive mode, which then again is not suitable for novices.

(btw, I don't think this is a Platform dependent bug, so changing i686
to All would be right.)
Comment 6 euphgeek 2005-03-03 17:46:20 EST
Kernel 2.6.10-1.741_FC3 seems to fix this. 
Comment 7 Dave Jones 2005-07-15 14:12:48 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 euphgeek 2005-07-17 11:58:02 EDT
This seems to have only been a problem with kernel 2.6.9.  When I updated to
kernel 2.6.10, the problem disappeared.  Fedora Core 4 does not seem to have
this problem.  As far as I'm concerned, this bug is fixed.

Note You need to log in before you can comment on or make changes to this bug.