Bug 1438219 - Python 3.6 installs Makefile to an incorrect config dir
Summary: Python 3.6 installs Makefile to an incorrect config dir
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3
Version: rawhide
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-02 04:09 UTC by fedora.dm0
Modified: 2017-04-28 14:35 UTC (History)
9 users (show)

Fixed In Version: python3-3.6.1-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 14:35:48 UTC
Type: Bug


Attachments (Terms of Use)

Description fedora.dm0 2017-04-02 04:09:49 UTC
Description of problem:
The Python 3.6 RPM installs its Makefile to an incorrect directory.  The sysconfig module generates the directory name with a multiarch suffix now.

Version-Release number of selected component (if applicable):
>=3.6.0

How reproducible:
Always

Steps to Reproduce:
1. python3.6 -c 'import sysconfig; print(sysconfig.get_makefile_filename())'

Actual results:
The returned file /usr/lib64/python3.6/config-3.6m-x86_64-linux-gnu/Makefile does not exist.  It is installed to /usr/lib64/python3.6/config-3.6m/Makefile instead.

Expected results:
The Makefile should be present at the path returned by the sysconfig module.

Comment 1 Charalampos Stratakis 2017-04-03 13:15:15 UTC
This is due to http://bugs.python.org/issue23968 change which was introduced in Python 3.6

Patch 205 [0] was not updated to reflect that, so LIBPL will actually need to be $(LIBDEST)/config-$(LDVERSION)-${PLATFORM_TRIPLET}


[0] http://pkgs.fedoraproject.org/cgit/rpms/python3.git/tree/00205-make-libpl-respect-lib64.patch

Comment 2 Charalampos Stratakis 2017-04-03 15:52:37 UTC
A small correction. It should be:

$(LIBDEST)/config-$(LDVERSION)-$(MULTIARCH)

Will test the changes and will push the fix the next days.

Comment 3 Miro Hrončok 2017-04-03 16:55:22 UTC
Note: This also affects the python36 package.

Comment 4 Charalampos Stratakis 2017-04-05 16:19:09 UTC
Pushed and building for rawhide:

https://src.fedoraproject.org/cgit/rpms/python3.git/commit/?h=master&id=bea97d96d29c1893f4c695da96a9d62f69618ff6

https://koji.fedoraproject.org/koji/taskinfo?taskID=18801703

I will not push it yet for Fedora 26 as I am waiting for the resolution of http://bugs.python.org/issue29943 first.

Comment 5 Fedora Update System 2017-04-18 18:03:25 UTC
python3-3.6.1-3.fc26 python3-docs-3.6.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 6 Fedora Update System 2017-04-19 12:51:35 UTC
python3-3.6.1-3.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 7 Fedora Update System 2017-04-19 16:47:11 UTC
python3-3.6.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 8 Fedora Update System 2017-04-19 16:53:15 UTC
python3-3.6.1-4.fc26 python3-docs-3.6.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 9 Fedora Update System 2017-04-19 16:53:37 UTC
python3-3.6.1-4.fc26 python3-docs-3.6.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 10 Fedora Update System 2017-04-20 02:22:54 UTC
python3-3.6.1-4.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 11 Fedora Update System 2017-04-28 14:35:48 UTC
python3-3.6.1-4.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.