Bug 1438258 - Acer Aspire One ZG5 produces WARN_ON on every boot
Summary: Acer Aspire One ZG5 produces WARN_ON on every boot
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 26
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: x86Tracker
TreeView+ depends on / blocked
 
Reported: 2017-04-02 13:36 UTC by Alex Villacís Lasso
Modified: 2018-02-19 16:19 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-02-19 16:19:35 UTC


Attachments (Terms of Use)
Output of dmesg showing the bug (61.80 KB, text/plain)
2017-04-02 13:36 UTC, Alex Villacís Lasso
no flags Details
Output of lspci -v (8.84 KB, text/plain)
2017-04-02 13:38 UTC, Alex Villacís Lasso
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 98930 None None None 2017-04-03 17:36 UTC

Description Alex Villacís Lasso 2017-04-02 13:36:03 UTC
Created attachment 1268211 [details]
Output of dmesg showing the bug

Description of problem:
Machine is an Acer Aspire ZG5 with Fedora 25 i686 with latest updates as of 2017-04-01. This machine has its internal flat panel display, and also a VGA connector on the side (currently unused).

On every single boot, the kernel logs a pair of WARN_ON backtraces and taints the kernel.

Version-Release number of selected component (if applicable):
kernel-PAE-4.10.6-200.fc25.i686

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora 25 i686 on an Acer Aspire One ZG5
2.
3.

Actual results:
A pair of WARN_ON backtraces are logged on dmesg at the moment the kernel loads the intel KMS driver and switches to graphics mode.

Expected results:
No backtraces

Additional info:
This backtrace is tainting the kernel. Due to this, there is a later issue that ABRT refuses to report.

Comment 1 Alex Villacís Lasso 2017-04-02 13:38 UTC
Created attachment 1268212 [details]
Output of lspci -v

Comment 2 Alex Villacís Lasso 2017-10-05 04:49:54 UTC
Still present in kernel-PAE-4.12.14-300.fc26.i686 under Fedora 26.

Comment 3 Alex Villacís Lasso 2017-10-05 04:55:13 UTC
This same machine is now affected by a severe screen corruption when booting kernel-PAE-4.13.4-200.fc26.i686 as described in https://bugzilla.redhat.com/show_bug.cgi?id=1498725 .

Comment 4 Alex Villacís Lasso 2017-10-17 20:55:47 UTC
I was asked to test:

git://github.com/vsyrjala/linux.git plane_sanitation_2_v4.13

and I can confirm that the applied patches fix this bug (as well as #1498725).

Comment 5 Jeff Backus 2017-11-04 14:56:00 UTC
Hi folks,

It sounds like this patch fixes the issue. What is the status of it? Are we still waiting for it to show up in the mainline kernel? Any chance we could make a patched version of the kernel available for testing? (e.g. in a copr) It looks like there are a few other bugs related to this:
* Bug 1507055 (https://bugzilla.redhat.com/show_bug.cgi?id=1507055)
* Bug 1498275 (https://bugzilla.redhat.com/show_bug.cgi?id=1498725)

Thanks!

Comment 6 Jeff Backus 2017-11-04 15:00:09 UTC
Gah! that is bug 1498725. And pardon my lack of experience with BZ.. :)

Comment 7 Alex Villacís Lasso 2018-02-19 16:19:35 UTC
With kernel 4.15.3-300.fc27.i686 this bug has been fixed. Thanks!


Note You need to log in before you can comment on or make changes to this bug.