Bug 143829 - /etc/init.d/postgresql service reports FAILED on successful startup
/etc/init.d/postgresql service reports FAILED on successful startup
Status: CLOSED DUPLICATE of bug 141811
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-29 09:28 EST by David Fraser
Modified: 2013-07-02 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Fraser 2004-12-29 09:28:20 EST
Description of problem:
The postgresql service script uses pidof to determine if postgresql
has started properly. However it is looking for /usr/bin/postmaster
which is a symlink to /usr/bin/postgresql and so it doesn't find the
processes and reports fairly

Version-Release number of selected component (if applicable):
postgresql-server-7.4.6-2
SysVinit-2.85-35

How reproducible:
Consistently

Steps to Reproduce:
1. Run /etc/init.d/postgresql restart
  
Actual results:
reports FAILED

Expected results:
reports OK

Additional info:
Comment 1 Tom Lane 2004-12-29 12:37:04 EST
This is a pidof bug --- that particular release of SysVinit is broken.

*** This bug has been marked as a duplicate of 141811 ***
Comment 2 David Fraser 2004-12-29 12:54:01 EST
The new SysVinit doesn't seem to be released for Fedora:
The development RPMs branch shows SysVinit-2.85-35.i386.rpm:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

I tried to say that on the RHEL bug this was marked as a duplicate of
but was told I'm not allowed :-)
Should I file another bug about that or should it be released
automatically (and when :-))?
Comment 3 Tom Lane 2004-12-29 13:22:50 EST
I don't know what notting's plans are for fixing the problem in devel
tip.  In the meantime I'd suggest forcibly downgrading to the latest
released FC3 version, SysVinit-2.85-34.  Or you could just ignore the
bleating from the init script for now ;-)
Comment 4 Bill Nottingham 2004-12-29 19:58:46 EST
Yeah, need to build a new devel version at some point.
Comment 5 Red Hat Bugzilla 2006-02-21 14:07:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.