Bug 143833 - RHN Applet appears to be leaking memory
RHN Applet appears to be leaking memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Beth Nackashi
:
Depends On:
Blocks: 168424 169775
  Show dependency treegraph
 
Reported: 2004-12-29 11:44 EST by John T. Rose
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0103
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:29:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John T. Rose 2004-12-29 11:44:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
After 2 days up I noticed unusual swap usage and discovered

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 3406 root      25  10  356M 222M  7180 S N   0.0 22.8   1:18   0
rhn-applet-gui

and it is continuing to grow in size as time passes.


Version-Release number of selected component (if applicable):
rhn-applet-2.1.18-4

How reproducible:
Didn't try

Steps to Reproduce:
1.Restart rhn-applet-gui
2.Watch it grow
3.
    

Actual Results:  I'm not claiming reproduction because I haven't
waited 2 days to see if it becomes so huge again.

Additional info:
Comment 1 John T. Rose 2005-01-03 17:37:17 EST
I've noticed throughout the day on an intel box that this doesn't seem
to be happening.  It is happening on an (1) AuthenticAMD AMD
Athlon(tm) XP 2600+ 2131 MHZ box.  I hope that helps narrow it down.

John
Comment 2 John T. Rose 2005-01-10 11:08:14 EST
Today on an intel box I see the rhn-applet-gui using 469M, 243M
resident, 4796 shared, so my previous guess about it being AMD related
is wrong.  I guess for now I'll just stop using it.

John
Comment 3 Max Spevack 2005-01-10 11:22:15 EST
Thanks for your additional comments.  Developer is looking at it.
Comment 20 Robin Norwood 2005-11-30 16:32:11 EST
Ok, finally tracked this down to leaking SSLConnections from rhnlib.rpclib. 
Mihai was able to track it further for me, and can probably elaborate from there.
Comment 21 Mihai Ibanescu 2005-12-01 16:42:44 EST
Fixed in rhnlib-1.8.2-1.p22.1 or newer.
Comment 22 Beth Nackashi 2005-12-16 13:27:52 EST
Verified memory usage grows out of control and test fails on i386, ia64, and
x86_64 with rhn-applet-2.1.18-4 and rhnlib-1.8-6.p22.

Verified memory usage stays stable and test passes on i386, ia64, and x86_64
with rhnlib-1.8.2-1.p22.1.

Ran rhn-applet-gui on i386, ia64, and x86_64 overnight and monitored memory
usage with rhnlib-1.8.2-1.p22.1.  No issues.

i386:
[root@rlx-3-04 rhn_applet]# ps auxww | grep applet
root     20705  0.2  0.7 25532 14548 pts/0   SN   13:24   0:00 /usr/bin/python
/usr/bin/rhn-applet-gui

ia64:
root     21249  1.6  1.7 90976 34640 pts/0   SN   13:25   0:03 /usr/bin/python
/usr/bin/rhn-applet-gui

x86_64:
[root@test05-64 root]#  ps auxww | grep applet
root      3844  0.2  0.9 172532 19604 pts/0  SN   13:26   0:00 /usr/bin/python
/usr/bin/rhn-applet-gui

PASSES_QA



Comment 23 Ryan Sweat 2005-12-20 14:36:45 EST
Is rhnlib-1.8.2-1.p22.1 available?
Comment 24 Clifford Perry 2006-01-05 10:51:24 EST
New version of rhnlib is *not* available yet as a public beta for Enterprise
Linux 3 line of products. It is available as public beta on the Enterprise 4
channels on RHN. 

rhnlib-1.8.2-1.p23.1.noarch   	 RHEL WS (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch 	RHEL ES (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch 	RHEL AS (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch   	 Red Hat Desktop (v. 4 for x86) Beta

Regards,
Clifford.
Comment 26 Red Hat Bugzilla 2006-03-15 10:29:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0103.html

Note You need to log in before you can comment on or make changes to this bug.