Bug 1438388 - [abrt] [faf] sssd: unknown function(): /usr/libexec/sssd/sssd_pam killed by 6
Summary: [abrt] [faf] sssd: unknown function(): /usr/libexec/sssd/sssd_pam killed by 6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Sudhir Menon
URL: http://faf.lab.eng.brq.redhat.com/faf...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-03 10:15 UTC by Steeve Goveas
Modified: 2020-05-02 18:39 UTC (History)
10 users (show)

Fixed In Version: sssd-1.15.2-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:04:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4397 None None None 2020-05-02 18:39:20 UTC
Red Hat Product Errata RHEA-2017:2294 normal SHIPPED_LIVE sssd bug fix and enhancement update 2017-08-01 12:39:55 UTC

Description Steeve Goveas 2017-04-03 10:15:24 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/0a2ee7591f48600ab792c8ee8febb21f27ab81a2/

This crash was also seen in 7.3
http://faf.lab.eng.brq.redhat.com/faf/reports/1762/

Comment 2 Lukas Slebodnik 2017-04-03 10:29:29 UTC
Do you have a reasonable reproducer?
Abrt report is not enough.

Comment 5 Lukas Slebodnik 2017-04-04 07:04:56 UTC
Please provide reasonable steps to reproduce.

Comment 7 Sumit Bose 2017-04-10 12:01:28 UTC
Steeve was so kind to provide me access to one of his test system showing this issue. I think this issues was exposed by https://bugzilla.redhat.com/show_bug.cgi?id=1438374. The backend crashes, the frontend has to setup a new connection which might take some time especially if the backend crashes agan during this time. If then SSSD is shut down the hash might already contain a connection object, although not properly initialized, to avoid multiple initializations.

I prepared a test build with the NULL check before calling dbus_connection_unregister_object_path() and hope that Steeve can confirm that it fixes the issue.

Comment 8 Sumit Bose 2017-04-10 18:36:49 UTC
Upstream ticket:
https://pagure.io/SSSD/sssd/issue/3367

Comment 10 Lukas Slebodnik 2017-04-12 13:30:37 UTC
master:
* 35186217d44d0138a1aedf7a4db72249b2c40e66

sssd-1-14:
* 72da8009f75cb597d436aeba78dfbd1bc30a7aa4

sssd-1-13:
* a5afe4709ab4946068d9c38d6fc4bfdd87cd687f

Comment 12 Sudhir Menon 2017-05-30 07:23:38 UTC
Marking the bug as VERIFIED.
Tested using  ipa-server-4.5.0-13.el7.x86_64 on RHEL7.4

Comment 14 errata-xmlrpc 2017-08-01 09:04:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2294


Note You need to log in before you can comment on or make changes to this bug.