Bug 143839 - ipvsadm does not include development library and headers
Summary: ipvsadm does not include development library and headers
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: ipvsadm (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-29 18:39 UTC by Need Real Name
Modified: 2009-04-16 20:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 22:56:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2004-12-29 18:39:32 UTC
Description of problem:

Some 3rd party software requires libipvs.a and libipvs.h to build. 
This is built as part of ipvsadm's build process, but the files are
not installed.

Version-Release number of selected component (if applicable):

ipvsadm-1.21-9.ipvs108

How reproducible:

100%

Steps to Reproduce:
1. install ipvsadm-1.21-9.ipvs108
2. look for libipvs.a and libipvs.h
3. notice that they are missing
  
Actual results:

The files are not installed.

Expected results:

The library and header files should either be included in the ipvsadm
package, or they should be installed as a separate -devel package.

Additional info:

Comment 1 Lon Hohberger 2005-01-03 16:10:16 UTC
Sending to owner of ipvsadm

Comment 3 Lon Hohberger 2005-02-07 22:56:25 UTC
After looking, it's not designed to be installed for general
consumption; it's for internal use of the ipvsadm tool.

There are some problems which will need to be fixed upstream before a
-devel package will be provided, mainly:

- reentrancy/thread-safety issues
- corresponding dynamic library (mostly build related)




Note You need to log in before you can comment on or make changes to this bug.