Bug 143840 - Wrong dependencies for gimp 2.2 / GTK2
Wrong dependencies for gimp 2.2 / GTK2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-29 14:01 EST by Berend Veldkamp
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-30 10:52:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Berend Veldkamp 2004-12-29 14:01:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I upgraded Gimp 2.0 to Gimp 2.2 with the rpm found here:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/gimp-2.2.0-1.i386.rpm

But when I start Gimp now, I get the following errors:

(gimp:5315): GLib-GObject-WARNING **: specified class size for type
`GimpContain
erEntry' is smaller than the parent type's `GtkEntry' class size

(gimp:5315): GLib-GObject-CRITICAL **: file gtype.c: line 2319
(g_type_add_inter
face_static): assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gimp:5315): GLib-GObject-CRITICAL **: file gobject.c: line 819
(g_object_new): 
assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gimp:5315): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
535 (gimp_
container_view_set_preview_size): assertion `GIMP_IS_CONTAINER_VIEW
(view)' fail
ed

(gimp:5315): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
306 (gimp_
container_view_set_container): assertion `GIMP_IS_CONTAINER_VIEW
(view)' failed

(gimp:5315): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
450 (gimp_
container_view_set_context): assertion `GIMP_IS_CONTAINER_VIEW (view)'
failed

(gimp:5315): Gtk-CRITICAL **: file gtkwidget.c: line 5592
(gtk_widget_set_size_r
equest): assertion `GTK_IS_WIDGET (widget)' failed

(gimp:5315): Gtk-CRITICAL **: file gtkbox.c: line 373
(gtk_box_pack_start): asse
rtion `GTK_IS_WIDGET (child)' failed
Segmentation fault

Upgrading gtk to version gtk2-2.6.0-1 (also on the site mentioned
above) solved this problem. It seems that some dependencies are not
correct.

Version-Release number of selected component (if applicable):
gimp-2.0.5-5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 3
2. Upgrade Gimp to version 2.2.0-1
3. Start Gimp
    

Actual Results:  Several error messages, see description. Gimp does
not start.

Expected Results:  Gimp should start with no error messages

Additional info:
Comment 1 Nils Philippsen 2004-12-30 10:52:33 EST
I won't fix this because it would because the burden to maintain separate spec
files for the various FC releases doesn't outweigh the benefit of being able to
run Rawhide gimp on FC3, especially if gimp-2.2.1 will be pushed to
fc3-updates-candidate soon (grab the packages from
http://people.redhat.com/nphilipp/BETA/gimp until they hit the mirrors).
Comment 2 Nils Philippsen 2004-12-30 10:59:48 EST
Strike "because it would" above. Ouch.
Comment 3 Manish Singh 2005-02-21 17:22:16 EST
At least update the dependencies to the latest gtk 2.4 please (where the
GtkEntry struct size is fixed), as this is frequently reported in our bug tracker.

As it is, it's way to easy for people to upgrade gimp but not gtk and get the
resultant breakage.
Comment 4 Nils Philippsen 2005-02-23 04:50:10 EST
The new gimp 2.2.4 packages require gtk2 >= 2.4.14 and should hit
Rawhide/Updates soon.

Note You need to log in before you can comment on or make changes to this bug.