Bug 1438412 - In Hosted Engine setup when the lun is not empty and you deploy with answer file without Force=True get one hour of loop
Summary: In Hosted Engine setup when the lun is not empty and you deploy with answer f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: 2.2.1
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On: 1455169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-03 11:47 UTC by Kobi Hakimi
Modified: 2018-02-22 09:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-22 09:58:36 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+


Attachments (Terms of Use)

Description Kobi Hakimi 2017-04-03 11:47:44 UTC
Description of problem:
In Hosted Engine setup when the lun is not empty and you deploy with answer file without Force=True get one hour of loop

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.1.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Make sure the following on answer file(/etc/ansible-ovirt/answer):
     - missing the parameter:
       OVEHOSTED_ENGINE/forceCreateVG=bool:True 
     - the lun id is lun which is dirty(not empty)

2. Deploy manually the hosted-engine with --config-append
   like:
   hosted-engine --deploy --config-append=/etc/ansible-ovirt/answer


Actual results:
The hosted-engine setup get into endless loop(one hour until the timeout):
[root@puma23 ansible-ovirt]# hosted-engine --deploy --config-append=/etc/ansible-ovirt/answers
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
[ INFO  ] Hardware supports virtualization
          Configuration files: ['/etc/ansible-ovirt/answers']
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20170330131119-whwdls.log
          Version: otopi-1.6.1 (otopi-1.6.1-1.el7ev)
[ INFO  ] Detecting available oVirt engine appliances
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== STORAGE CONFIGURATION ==--
         
          Please specify the iSCSI portal user: 
          Please specify the target name (iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6) [iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6]: 
          The following luns have been found on the requested target:
          	[1]	3600a09803830347a625d467a79745237	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[2]	3600a09803830347a625d467a79745238	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[3]	3600a09803830347a625d467a79745239	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[4]	3600a09803830347a625d467a7974522d	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[5]	3600a09803830347a625d467a79745241	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[6]	3600a09803830347a625d467a79745242	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[7]	3600a09803830347a625d467a7974565a	130GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          The selected device is already used.
          To create a vg on this device, you must use Force.
          WARNING: This will destroy existing data on the device.
          (Force, Abort)[Abort]? 
[ ERROR ] The selected LUN is dirty; please clean it and retry
          Please specify the target name (iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6) [iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6]: 
          The following luns have been found on the requested target:
          	[1]	3600a09803830347a625d467a79745237	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[2]	3600a09803830347a625d467a79745238	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[3]	3600a09803830347a625d467a79745239	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[4]	3600a09803830347a625d467a7974522d	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[5]	3600a09803830347a625d467a79745241	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[6]	3600a09803830347a625d467a79745242	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[7]	3600a09803830347a625d467a7974565a	130GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
[ ERROR ] The selected LUN is dirty; please clean it and retry
          Please specify the target name (iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6) [iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6]: 
          The following luns have been found on the requested target:
          	[1]	3600a09803830347a625d467a79745237	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[2]	3600a09803830347a625d467a79745238	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[3]	3600a09803830347a625d467a79745239	150GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
          	[4]	3600a09803830347a625d467a7974522d	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[5]	3600a09803830347a625d467a79745241	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[6]	3600a09803830347a625d467a79745242	50GiB	NETAPP	LUN C-Mode
          		status: free, paths: 1 active
         
          	[7]	3600a09803830347a625d467a7974565a	130GiB	NETAPP	LUN C-Mode
          		status: used, paths: 1 active
         
[ ERROR ] The selected LUN is dirty; please clean it and retry
          Please specify the target name (iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6) [iqn.1992-08.com.netapp:sn.9a14187dd2e911e4bbb900a09861387c:vs.6]: 
.
.
.


Expected results:
To exit the installation with error. 

Additional info:

Comment 1 Yaniv Lavi 2017-04-12 11:15:01 UTC

*** This bug has been marked as a duplicate of bug 1438407 ***

Comment 2 Kobi Hakimi 2017-04-12 11:43:30 UTC
IMHO it is different bug...

Please add detailed reason why it is duplicate

Comment 3 Ido Rosenzwig 2018-01-02 14:09:51 UTC
Works for me.

Comment 4 Nikolai Sednev 2018-02-18 16:06:20 UTC
Forth to our converstation with Kobi, this bug should be tested on vintage SHE deployments.
Works for me on these components:
ovirt-hosted-engine-ha-2.2.5-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.10-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-693.19.1.el7.x86_64 #1 SMP Thu Feb 1 12:34:44 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

alma04 ~]# hosted-engine --deploy --noansible --config-append=/root/answers.conf
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
[ INFO  ] Hardware supports virtualization
          Configuration files: ['/root/answers.conf']
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20180218180302-8pde1z.log
          Version: otopi-1.7.7 (otopi-1.7.7-1.el7ev)
[ INFO  ] Detecting available oVirt engine appliances
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Generating libvirt-spice certificates
[ INFO  ] Stage: Environment customization
         
          --== STORAGE CONFIGURATION ==--
         
[ INFO  ] Connecting to the storage server
          The following luns have been found on the requested target:
                [1]     LUN1    3514f0c5a516015ce       80GiB   XtremIO XtremApp
                        status: used, paths: 1 active
         
                [2]     LUN2    3514f0c5a516015cf       81GiB   XtremIO XtremApp
                        status: free, paths: 1 active
         
                [3]     LUN3    3514f0c5a516015cd       82GiB   XtremIO XtremApp
                        status: free, paths: 1 active
         
                [4]     LUN4    3514f0c5a516015cc       83GiB   XtremIO XtremApp
                        status: free, paths: 1 active
         
[ INFO  ] Connecting to the storage server
[ ERROR ] The selected device already contains a storage domain.
[ ERROR ] Setup of additional hosts using this software is not allowed anymore. Please use the engine web interface to deploy any additional hosts.
[ ERROR ] Failed to execute stage 'Environment customization': Setup of additional hosts using this software is not allowed anymore. Please use the engine web interface to deploy any additional hosts.
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20180218180334.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20180218180302-8pde1z.log

Comment 5 Sandro Bonazzola 2018-02-22 09:58:36 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.