Bug 1438438 - AssertionError from DNF
Summary: AssertionError from DNF
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-03 12:28 UTC by George R. Goffe
Modified: 2017-05-05 13:34 UTC (History)
6 users (show)

Fixed In Version: dnf-2.4.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-05 13:34:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzip'd log file (9.85 KB, application/x-gzip)
2017-04-15 02:03 UTC, George R. Goffe
no flags Details
gzipped flat file with info requested... (1.83 KB, application/x-gzip)
2017-04-18 18:47 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2017-04-03 12:28:48 UTC
Description of problem:

Updating this system with dnf gives an apparent error message but there's no text or apparent reason for the error message (see below)

Version-Release number of selected component (if applicable):
dnf-2.2.0-1.fc27.noarch

How reproducible:
always

Steps to Reproduce:
1.dnf -y group install --with-optional 'KDE Plasma Workspaces'
2.
3.

Actual results:
see below

Expected results:
successful system upgrade

Additional info:
dnf -y group install --with-optional 'KDE Plasma Workspaces'
Last metadata expiration check: 3:05:33 ago on Sun Apr 02 22:40:06 2017 PDT.
Group 'base-x' is already installed.
Group 'Standard' is already installed.
Group 'Core' is already installed.
Group 'Dial-up Networking Support' is already installed.
Group 'Fonts' is already installed.
Group 'Input Methods' is already installed.
Group 'Multimedia' is already installed.
Group 'Common NetworkManager Submodules' is already installed.
Group 'Hardware Support' is already installed.
Group 'Printing Support' is already installed.
Group 'Guest Desktop Agents' is already installed.
Group 'KDE' is already installed.
Dependencies resolved.
AssertionError:

Comment 1 Jaroslav Rohel 2017-04-05 11:41:24 UTC
Please can you provide additional data. 
Can you attache the file /var/log/dnf.log immediately after appearance of the problem.

Comment 2 George R. Goffe 2017-04-05 20:28:07 UTC
Jaroslav

Thanks for your attention and time you spent on this bug.

The file is rather large (> 534000 k after gzip) and contains only one instance of "AssertionError". Additionally, the problem appears to not be reproducible at this time.

Given the above, do you want me to send the file or parts of the file or put this bug on hold? Now that I know what you will need, I can do a better job of capturing this info.

George...

Comment 3 Jaroslav Mracek 2017-04-11 18:59:27 UTC
Ok, please can you dissect only information regarding to the assertion plus few lines before and after and attach it as a new file? It should be not extremely big. I need to know from where the assertion was raised.

Comment 4 George R. Goffe 2017-04-15 02:03 UTC
Created attachment 1271774 [details]
gzip'd log file

Jaroslav,

Here's the log from the dnf assertion problem. I tried to get the entries from just the error condition (start/end).

Let me know if you need more info.

Thanks for your help,

George...

Comment 5 Jaroslav Mracek 2017-04-18 14:44:52 UTC
I still cannot find a reproducer. Probably some questions will help:

1. Can you still reproduce the problem on your system?

2. Was env group 'KDE Plasma Workspaces' already installed before problem appearance? Please can you provide output from "dnf group list" and "dnf group list --hidden"

Unfortunately I will have additional questions after this first two.

Comment 6 George R. Goffe 2017-04-18 18:47 UTC
Created attachment 1272404 [details]
gzipped flat file with info requested...

Jaroslav,

#1 -- I haven't seen this error since reporting it here. There may have been more info that should have been displayed along with the "Assertion". My question is, "How can the word 'assertion' be written but no other data?". Maybe some sort of "end of data" indicator would be helpful?

#2 -- data in the appended file...

THANKS for your attention to this bug.

George...

Comment 7 George R. Goffe 2017-04-18 22:39:17 UTC
Jaroslav,

I forgot to answer the first part of your second question. Yes, "KDE Plasma Workspaces" was previously installed.

George...

Comment 8 Jaroslav Mracek 2017-04-19 09:37:31 UTC
I create a pull-request https://github.com/rpm-software-management/dnf/pull/786 that should prevent the raising of assertion. Because I was unable find reproducer I cannot fix the primary issue. I guess that problem was that the install of group with --optional result that diff between installed and available groups produces strange result that some of packages were marked as removal mark. Therefore please if in future you will see such a result, please report it as a bug and we can solve the primary issue. Thanks...

Comment 9 George R. Goffe 2017-04-20 06:37:37 UTC
Jaroslav,

I will do this when/if it ever happens again.

Thanks for your hard work with this bug,

George...

Comment 10 Fedora Update System 2017-05-02 15:40:32 UTC
dnf-plugins-core-2.0.0-1.fc26 libdnf-0.8.2-1.fc26 dnf-2.4.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d

Comment 11 Fedora Update System 2017-05-04 09:48:36 UTC
dnf-2.4.0-1.fc26 dnf-plugins-core-2.0.0-1.fc26 dnf-plugins-extras-2.0.0-1.fc26 libdnf-0.8.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d

Comment 12 Fedora Update System 2017-05-04 22:04:55 UTC
dnf-2.4.0-1.fc26, dnf-plugins-core-2.0.0-1.fc26, dnf-plugins-extras-2.0.0-1.fc26, libdnf-0.8.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e95959f0d

Comment 13 Fedora Update System 2017-05-05 13:34:32 UTC
dnf-2.4.0-1.fc26, dnf-plugins-core-2.0.0-1.fc26, dnf-plugins-extras-2.0.0-1.fc26, libdnf-0.8.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.