Bug 143849 - Pear command gives errors in Common.php
Pear command gives errors in Common.php
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-29 19:47 EST by Rodrigo Damazio
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.3.11-2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 03:51:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodrigo Damazio 2004-12-29 19:47:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
pear command will not work with any options given. It always gives
repeated errors about "illegal offset type in common.php" in lines 91
and 108. Looking at those lines, there seems to be nothing wrong.
Possibly a php bug.

Version-Release number of selected component (if applicable):
php-pear4.3.10-3.2

How reproducible:
Always

Steps to Reproduce:
1. Run command 'pear' with any options (e.g. help)


Actual Results:  (repeated error lines not shown)
Warning: Illegal offset type in Common.php on line 91
 
Warning: Illegal offset type in Common.php on line 108
PHP Fatal error:  Cannot instantiate non-existent class: 
pear_frontend_cli in /usr/share/pear/PEAR/Command.php on line 144


Expected Results:  A help screen, or any output relative to the
options given.

Additional info:

Didn't happen in version 4.3.9-3.
Happens even after downloading the PEAR package from pear.php.net and
replacing the files.
Comment 1 Joe Orton 2005-04-19 03:51:33 EDT
Fixed in 4.3.11 update, thanks for the report:

http://www.redhat.com/archives/fedora-announce-list/2005-April/msg00033.html

Note You need to log in before you can comment on or make changes to this bug.