Bug 143852 - autoconf AC_CHECK_TYPE() macro generates compiler warnings
Summary: autoconf AC_CHECK_TYPE() macro generates compiler warnings
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autoconf   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
low
Target Milestone: ---
: ---
Assignee: Karsten Hopp
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-30 01:37 UTC by Michael Jennings (KainX)
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 12:07:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Jennings (KainX) 2004-12-30 01:37:08 UTC
Description of problem:
Use of the AC_CHECK_TYPE() autoconf macro fails when the compiler
flags contain -Werror due to missing prototypes for longval() and
ulongval().

Version-Release number of selected component (if applicable):

autoconf-2.59-5

How reproducible:

Every time.

Steps to Reproduce:
1.  Use AC_CHECK_TYPE(char, 1) in configure.in, or download
libast-0.6.1.tar.gz from http://www.eterm.org/download/ and use that.
2.  export CFLAGS='-O0 -g3 -march=pentiumpro -W -Wall
-Wmissing-prototypes -Wmissing-declarations -Wall -Werror -std=c99
-pedantic'
3.  ./autogen.sh && make distcheck  
  
Actual results:

checking size of char... configure: error: cannot compute sizeof
(char), 77
See `config.log' for more details.
make: *** [distcheck] Error 1

Expected results:

configure script should complete without errors though "make
distcheck" will fail later on for other reasons.

Additional info:

Comment 1 Daniel Reed 2005-01-21 19:43:48 UTC
This is now fixed in upstream Autoconf CVS, and will be available in the next
upstream release.

Comment 4 Karsten Hopp 2006-05-08 12:07:48 UTC
added patch to CVS so that this doesn't get lost.
this will be fixed when we need to issue the next erratum


Note You need to log in before you can comment on or make changes to this bug.