Bug 1438601 - Handle issues with loading execution_plan [NEEDINFO]
Summary: Handle issues with loading execution_plan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Lukas Pramuk
URL:
Whiteboard:
: 1400688 1406168 1438928 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-03 22:05 UTC by Ivan Necas
Modified: 2020-09-10 10:25 UTC (History)
11 users (show)

Fixed In Version: tfm-rubygem-foreman-tasks-0.7.14.14-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1446714 (view as bug list)
Environment:
Last Closed: 2017-06-20 17:23:47 UTC
Target Upstream Version:
mmccune: needinfo? (dcaplan)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 19147 0 None None None 2017-04-03 22:05:08 UTC
Red Hat Product Errata RHBA-2017:1553 0 normal SHIPPED_LIVE Satellite 6.2.10 Async Bug Release 2017-06-20 21:19:07 UTC

Description Ivan Necas 2017-04-03 22:05:06 UTC
There are various reasons that can cause the execution plan for a task not being available. We should still try
to not fail completely at those situations and try to show at least the data we have available in foreman_tasks_tasks table.

How to reproduce:

Follow http://projects.theforeman.org/issues/19146 for reproducer steps and go to the tasks details pages after doing so.

Expected results: the tasks page is still showing at least some data, not failing completely.

Current results: the tasks page is broken, returning 500 status code

Comment 1 Ivan Necas 2017-04-03 22:05:11 UTC
Created from redmine issue http://projects.theforeman.org/issues/19147

Comment 2 Ivan Necas 2017-04-03 22:05:17 UTC
Upstream bug assigned to inecas

Comment 4 Ivan Necas 2017-04-03 22:07:01 UTC
An example of such an error might be:

Oops, we're sorry but something went wrong Value (NilClass) '' is not any of: Dynflow::ExecutionPlan::Steps::Abstract.

Comment 5 Ivan Necas 2017-04-05 10:02:46 UTC
*** Bug 1438928 has been marked as a duplicate of this bug. ***

Comment 8 Ivan Necas 2017-05-10 13:21:56 UTC
*** Bug 1406168 has been marked as a duplicate of this bug. ***

Comment 9 Lukas Pramuk 2017-06-09 14:39:13 UTC
VERIFIED.

@satellite-6.2.10-3.0.el7sat.noarch
tfm-rubygem-foreman-tasks-0.7.14.14-1.el7sat.noarch

using manual reproducer described in comment#0:

5. Navigate to /foreman_tasks/tasks

REPRO:

(x) Oops, we're sorry but something went wrong Value (NilClass) '' is not any of: Dynflow::ExecutionPlan::Steps::Abstract.

vs.

FIX:

Actions::Katello::Repository::CapsuleGenerateAndSync N/A
Actions::Katello::Repository::Sync N/A
Actions::Katello::Repository::Sync N/A

>>> Tasks page/detail renders and tasks are listed even if there are invalid tasks

Comment 11 errata-xmlrpc 2017-06-20 17:23:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1553

Comment 14 Ivan Necas 2017-09-14 08:47:01 UTC
*** Bug 1400688 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.