Bug 1438602 - horizon gets deconfigued in step3 of updates
Summary: horizon gets deconfigued in step3 of updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Alex Schultz
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1438099
Blocks: 1421883 1438886
TreeView+ depends on / blocked
 
Reported: 2017-04-03 22:09 UTC by Alex Schultz
Modified: 2017-09-15 03:06 UTC (History)
7 users (show)

Fixed In Version: puppet-tripleo-6.3.0-8.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the OpenStack Dashboard service was configured in the wrong step of the deployment, resutling in horizon being temporarily unavailable during deployments and leading to additional 'httpd' service restarts. With this update, the OpenStack Dashboard configuration is fixed to occur at the same time as the rest of the 'httpd' configuration. As a result, horizon does not become temporarily unavailable when running the overcloud.
Clone Of: 1438099
: 1438886 (view as bug list)
Environment:
Last Closed: 2017-05-17 20:17:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 452785 None None None 2017-04-03 22:08:59 UTC
Launchpad 1678338 None None None 2017-04-03 22:08:59 UTC

Description Alex Schultz 2017-04-03 22:09:00 UTC
+++ This bug was initially created as a clone of Bug #1438099 +++

horizon gets deconfigured during update runs on an deployed cloud.

Steps to reproduce:
1) deploy overcloud
2) run deploy overcloud again
3) look at logs and notice that the horizon configuration is removed (in step3) and reapplied (in step4) of the subsequent run.

Logs:
step3 logs http://paste.openstack.org/show/605110/
step4 logs http://paste.openstack.org/show/605111/

Comment 2 errata-xmlrpc 2017-05-17 20:17:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.