Bug 1438604 - Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'
Summary: Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.10.7-0.0.15
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.1.1-1
: ---
Assignee: Ryan Barry
QA Contact: Yihui Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-03 22:19 UTC by Jason Brooks
Modified: 2017-05-11 09:25 UTC (History)
6 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.17.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:35:32 UTC
oVirt Team: Node
rule-engine: ovirt-4.1?
sbonazzo: blocker?
sbonazzo: planning_ack?
rbarry: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
install log from attempt w/ nfs storage (470.22 KB, text/plain)
2017-04-05 21:45 UTC, Jason Brooks
no flags Details
0413_version_cockpit.png (24.18 KB, image/png)
2017-04-14 07:21 UTC, Yihui Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 75253 master MERGED he: unset confirm_otopi after passing input 2017-04-10 15:13:08 UTC
oVirt gerrit 75417 ovirt-4.1 MERGED he: unset confirm_otopi after passing input 2017-04-10 15:13:19 UTC

Description Jason Brooks 2017-04-03 22:19:46 UTC
Description of problem:

On an install of an ovirt node based gluster cluster with hosted engine, the installer asks if you want to configure your host and cluster for Gluster. In some of my tests, the installer fails at this point, with an error message of `Failed to execute stage 'Environment customization'`. When I encounter this, I click "Restart Setup", advance through the setup process again, and am able to proceed normally. 

In the UI, the error is:

Failed to execute stage 'Environment customization': Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'

From the log:

2017-04-03 22:16:12 DEBUG otopi.context context._executeMethod:142 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/gr-he-setup/storage/nfs.py", line 497, in _customization_hc
    default=False,
  File "/usr/lib/python2.7/site-packages/ovirt_setup_lib/dialog.py", line 47, in queryBoolean
    default=true if default else false,
  File "/usr/share/otopi/plugins/otopi/dialog/machine.py", line 212, in queryString
    name=name
RuntimeError: Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'
2017-04-03 22:16:12 ERROR otopi.context context._executeMethod:151 Failed to execute stage 'Environment customization': Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'
2017-04-03 22:16:12 DEBUG otopi.context context.dumpEnvironment:760 ENVIRONMENT DUMP - BEGIN
2017-04-03 22:16:12 DEBUG otopi.context context.dumpEnvironment:770 ENV BASE/error=bool:'True'
2017-04-03 22:16:12 DEBUG otopi.context context.dumpEnvironment:770 ENV BASE/exceptionInfo=list:'[(<type 'exceptions.RuntimeError'>, RuntimeError("Invalid value provided to 'ENABLE_HC_GLUSTER_SERVICE'",), <traceback object at 0x55dfef0>)]'

Comment 1 Sahina Bose 2017-04-05 13:20:24 UTC
Ryan, this is part of the hosted engine deployment flow, not part of the gdeploy.

Comment 2 Ryan Barry 2017-04-05 13:28:27 UTC
Sahina -

I moved this because the cockpit hosted engine plugin has absolutely no host-side logic.

The gdeploy plugin DOES write values to the HEAnswerFile (though not this one). The HE plugin does not. The values the gdeploy plugin writes will then be used, which may affect the runtime of HE.

I don't have a gluster test environment, and it's possible that this bug is somehow related to the interaction of the keys the gdeploy plugin does write and ovirt-hosted-engine-setup.

I moved it for investigation. If there is no problem with the syntax (see src/helpers/GdeployUtil.js:GdeployUtil.createHEAnswerFileForGlusterStorage) and this bug is not reproducible, please let me know and I'll move it to ovirt-hosted-engine-setup.

But this is not a bug in cockpit-ovirt, outside of the potential of it being in gdeploy.

Comment 3 Jason Brooks 2017-04-05 19:14:41 UTC
I tried this yesterday with nfs storage, with a similar result. It errored out once before I restarted the setup and it worked the second time through.

Comment 4 Ryan Barry 2017-04-05 19:16:47 UTC
Can you grab the deployment logs from a failed try and attach them, please? They should be in /var/log/ovirt-hosted-engine-setup

Comment 5 Jason Brooks 2017-04-05 21:45:03 UTC
Created attachment 1269096 [details]
install log from attempt w/ nfs storage

Comment 6 Ryan Barry 2017-04-05 21:55:37 UTC
Thanks Jason!

Comment 7 Red Hat Bugzilla Rules Engine 2017-04-05 21:55:43 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 8 Ryan Barry 2017-04-05 21:58:11 UTC
Sandro -

This should also get blocker+, since it will happen every time the GPG_KEY needs confirmation, and should definitely make 4.1.1

Comment 9 Yihui Zhao 2017-04-06 04:58:36 UTC
Can reproduce the issue.

Test version:
rhvh-4.1-0.20170403.0+1


Test steps:
Deploy HE with NFS storage while accepting the gpg key.

Comment 10 Sandro Bonazzola 2017-04-06 08:28:37 UTC
(In reply to Ryan Barry from comment #8)
> Sandro -
> 
> This should also get blocker+, since it will happen every time the GPG_KEY
> needs confirmation, and should definitely make 4.1.1

proposed as blocker.

Comment 11 cshao 2017-04-06 09:08:57 UTC
(In reply to Yihui Zhao from comment #9)
> Can reproduce the issue.
> 
> Test version:
> rhvh-4.1-0.20170403.0+1
> 
> 
> Test steps:
> Deploy HE with NFS storage while accepting the gpg key.

Update version info for #c9,
Test version:
rhvh-4.1-0.20170403.0+1
imgbased-0.9.20-0.1.el7ev.noarch
ovirt-hosted-engine-ha-2.1.0.5-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0.5-1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.16.el7ev.noarch
cockpit-ws-126-1.el7.x86_64

Comment 12 Yihui Zhao 2017-04-06 10:29:25 UTC
(In reply to Yihui Zhao from comment #9)
> Can reproduce the issue.
> 
> Test version:
> rhvh-4.1-0.20170403.0+1
> 
> 
> Test steps:
> Deploy HE with NFS storage while accepting the gpg key.

Deploy HE via cmdline also meet the issue.

Comment 13 Sandro Bonazzola 2017-04-06 11:49:24 UTC
So moving ot ovirt-hsoted-engine-setup.

Comment 14 Simone Tiraboschi 2017-04-07 07:37:33 UTC
It seams a bug on the cockpit plugin:

hosted-engine-setup queries a value with a list of valid options (**%QValidValues: glusterfs|iscsi|fc|nfs3|nfs4) but the cockpit plugin responds with CONFIRM GPG_KEY=nfs3

Trying to reproduce also on CLI as for https://bugzilla.redhat.com/show_bug.cgi?id=1438604#c12

2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       **%QStart: OVEHOSTED_STORAGE_DOMAIN_TYPE
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       ### Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: 
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       **%QDefault: nfs3
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       **%QValidValues: glusterfs|iscsi|fc|nfs3|nfs4
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       **%QHidden: FALSE
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       ***Q:STRING OVEHOSTED_STORAGE_DOMAIN_TYPE
2017-04-05 21:00:02 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       **%QEnd: OVEHOSTED_STORAGE_DOMAIN_TYPE
2017-04-05 21:43:11 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:RECEIVE    CONFIRM GPG_KEY=nfs3
2017-04-05 21:43:11 DEBUG otopi.context context._executeMethod:142 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/gr-he-setup/storage/storage.py", line 897, in _early_customization
    default=ohostedcons.DomainTypes.NFS3,
  File "/usr/share/otopi/plugins/otopi/dialog/machine.py", line 212, in queryString
    name=name
RuntimeError: Invalid value provided to 'OVEHOSTED_STORAGE_DOMAIN_TYPE'
2017-04-05 21:43:11 ERROR otopi.context context._executeMethod:151 Failed to execute stage 'Environment customization': Invalid value provided to 'OVEHOSTED_STORAGE_DOMAIN_TYPE'

Comment 15 Yihui Zhao 2017-04-07 09:43:25 UTC
Update comment 12:

Deploy HE via cmdline don't  meet the issue, just meet when deploying via Cockpit.

Comment 16 Sandro Bonazzola 2017-04-07 12:04:32 UTC
Moved back to cockpit-ovirt, moving to POST since we have already a patch for it under review.

Comment 17 Yihui Zhao 2017-04-14 07:21:01 UTC
Created attachment 1271631 [details]
0413_version_cockpit.png

Comment 18 Yihui Zhao 2017-04-14 07:23:26 UTC
Can reproduce again.

Test version:
rhvh-4.1-0.20170413.0+1
ovirt-imageio-common-1.0.0-0.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-node-ng-nodectl-4.1.1-0.20170404.0.el7.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-setup-lib-1.1.0-1.el7ev.noarch
ovirt-host-deploy-1.6.3-1.el7ev.noarch
ovirt-imageio-daemon-1.0.0-0.el7ev.noarch
ovirt-hosted-engine-ha-2.1.0.5-2.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0.5-1.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.16.el7ev.noarch
rhvm-appliance-4.1.20170221.0-1.el7ev.noarch

Test steps:
Deploy HE with NFS storage while accepting the gpg key via cockpit.
Attachment: https://bugzilla.redhat.com/attachment.cgi?id=1271631

Comment 19 cshao 2017-04-14 13:27:09 UTC
Assigned this bug according #c18.

Comment 20 Ryan Barry 2017-04-14 14:07:35 UTC
This missed a build downstream, which is why it was not moved to MODIFIED...

Comment 21 Yihui Zhao 2017-04-18 10:56:24 UTC
Test version:
rhvh-4.1-0.20170417.0+1
cockpit-dashboard-135-4.el7.x86_64
cockpit-ovirt-dashboard-0.10.7-0.0.17.el7ev.noarch
cockpit-bridge-135-4.el7.x86_64
cockpit-ws-135-4.el7.x86_64
cockpit-system-135-4.el7.noarch
cockpit-storaged-135-4.el7.noarch
ovirt-imageio-common-1.0.0-0.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.17.el7ev.noarch
ovirt-setup-lib-1.1.0-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-host-deploy-1.6.3-1.el7ev.noarch
ovirt-imageio-daemon-1.0.0-0.el7ev.noarch
ovirt-hosted-engine-ha-2.1.0.5-2.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0.5-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-node-ng-nodectl-4.1.1-0.20170404.0.el7.noarch

Test steps:
1. Install RHVH4.1
2. Login to cockpit, subscribe to RHN, enable correct repos
3. Deploy HE with NFS storage while accepting the gpg key via cockpit.

Test result:
After step3,
Deploy HE successfully with NFS storage while accepting the gpg key via cockpit.


So this bug is fixed in redhat-virtualization-host-4.1-20170417.0, I will change the status to VERIFIED after the status is changed to ON_QA.

Comment 22 Yihui Zhao 2017-04-20 01:20:54 UTC
According to the comment21, change the status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.