Bug 143865 - gamin two orders of magnitude slower than fam
gamin two orders of magnitude slower than fam
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-30 07:44 EST by Mike Bird
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 08:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Bird 2004-12-30 07:44:24 EST
Description of problem:
courier-imap takes approximately 16 seconds to provide the next
message using gamin.  With fam0.0.17-1.FC3 (from FC2 - works fine in
FC3) courier-imap takes a small fraction of a second.  (Approx 32K
messages in 300 IMAP folders totalling 220MB.)


Version-Release number of selected component (if applicable):
0.0.17-1.FC3

How reproducible:
Always
Comment 1 Mike Bird 2004-12-30 07:47:29 EST
Correction:

Recommend fam-2.6.10-9.FC2 from FC2 updates.
Comment 2 Ivan Mitev 2005-03-27 11:58:01 EST
i've got exactly the same problem with an up to date FC2 and courier imap 4.0.2

when switching to gamin - 0.25 or 0.26 - mozilla thunderbird takes a few seconds
to display a message while it's instantaneous with fam (fam-2.6.10-9.FC2 or
2.7.0 from sgi's website)

mike, did you manage to solve the problem ? i've quickly done some tests and
looked at /tmp/gamin_debug but nothing seems anormal there ; i'll try to do more
debugging ...
Comment 3 Mike Bird 2005-03-27 13:44:22 EST
Solution for FC2 and FC3 is to ignore gamin and use fam-2.6.10-9.FC2.

Although we've started testing FC4t1, we haven't tried gamin or fam yet.
Comment 4 Vaclav "sHINOBI" Misek 2005-06-05 20:01:22 EDT
Please try the latest gamin from rawhide (take SRPM and recompile for FC3). It
seems to be fixing the problems for me (at least as far as I tested :-) ).
Comment 5 Ivan Mitev 2005-07-03 08:59:32 EDT
sorry for the late answer but at last i've managed to test gamin 0.1.1, and the
problem seems to be solved; great!

the next step is to check how gamin performs vs. fam in terms of ressource
usage... ; i'll try to post some info on that soon.
Comment 6 Vaclav "sHINOBI" Misek 2005-07-24 04:59:30 EDT
This bug can be closed as the gamin-0.1.1-1 is under updates and it solves this bug.

Note You need to log in before you can comment on or make changes to this bug.