Bug 1438671 - Replace Yumex-DNF with dnfdragora
Summary: Replace Yumex-DNF with dnfdragora
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact:
URL:
Whiteboard: ChangeAcceptedF27, SelfContainedChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-04 06:50 UTC by Jan Kurik
Modified: 2017-11-14 08:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 08:58:23 UTC
Type: ---


Attachments (Terms of Use)

Description Jan Kurik 2017-04-04 06:50:32 UTC
This is a tracking bug for Change: Replace Yumex-DNF with dnfdragora
For more details, see: https://fedoraproject.org//wiki/Changes/Replace_yumex-dnf_with_dnfdragora

Replace the current alternative graphical package manager.

Comment 1 Björn 'besser82' Esser 2017-04-04 07:59:06 UTC
Needed tasks for the change have been completed:

  * DNFDragora carries the needed Obsoletes/Provides and Yumex-DNF has been
    retired from F27.

  * Packages directly requiring Yumex-DNF are patched to properly work
    with DNFDragora and Requires are changed.

  * Needed changes to kickstart-files and Comps are merged.

Comment 2 Christian Stadelmann 2017-05-13 19:04:53 UTC
dnfdragora has some major regressions compared to yumex-dnf. I've reported some of them upstream as
https://github.com/manatools/dnfdragora/issues/37 https://github.com/manatools/dnfdragora/issues/38 https://github.com/manatools/dnfdragora/issues/48 https://github.com/manatools/dnfdragora/issues/49

Please fix those issues before retiring yumex-dnf.

Comment 3 Greg` 2017-07-06 01:21:16 UTC
any update on DNFDragora status?

Comment 4 Jan Kurik 2017-08-15 08:35:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 5 Woi 2017-08-31 13:50:45 UTC
I like to point out that update notifications are considered a release blocking bug for certain desktops [1]. It's also a very significant part of the user experience. So I like to the acceptance criteria. 
However, I could not find any information about which desktops environments are considered "release-blocking" by Fedora.

[1] https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria#Update_notification

Comment 6 Woi 2017-08-31 13:51:47 UTC
Sorry for the typo. Should be
"So I like to add this to the acceptance criteria."

Comment 7 Christian Stadelmann 2017-09-04 18:27:58 UTC
There is another replacement for yumex-dnf, rpmreaper.

Comment 8 Greg` 2017-09-07 00:27:10 UTC
i take it DNFDragora is Dead since there's no update to this? but my 2 cents, i would much prefer to keep yumex-dnf alive anyway ,  would it make sense to get Richard Hughes to possibly clean up the code of yumex-dnf ?

Comment 9 Christian Stadelmann 2017-09-07 07:13:37 UTC
(In reply to Greg` from comment #8)
> i take it DNFDragora is Dead since there's no update to this?

No, it isn't. Probably they are writing dnfdragora in their spare time and spare time is rare.

> but my 2 cents, i would much prefer to keep yumex-dnf alive anyway,  would it make sense to get Richard Hughes to possibly clean up the code of yumex-dnf ?

I doubt this will help as yumex-dnf is also lacking maintenance and has quite a few bugs.

Comment 10 Greg` 2017-09-09 00:49:47 UTC
(In reply to Christian Stadelmann from comment #9)
> (In reply to Greg` from comment #8)
> > i take it DNFDragora is Dead since there's no update to this?
> 
> No, it isn't. Probably they are writing dnfdragora in their spare time and
> spare time is rare.
> 
> > but my 2 cents, i would much prefer to keep yumex-dnf alive anyway,  would it make sense to get Richard Hughes to possibly clean up the code of yumex-dnf ?
> 
> I doubt this will help as yumex-dnf is also lacking maintenance and has
> quite a few bugs.

IMO this should go to as a F28 Feature as there is no Update to this Bug. an i cant see any updates in Koji to it since i think the 5th month of this year, 
at least someone like Hughes could clean up the code  an give it to someone to maintain it rather than start a New GUI Manager which IMO r3esembles Packagespit anyway


Note You need to log in before you can comment on or make changes to this bug.