Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1438710 - Backport new virt-rescue to RHEL 7
Backport new virt-rescue to RHEL 7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
Yehuda Zimmerman
:
Depends On: 1438709
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-04 05:07 EDT by Richard W.M. Jones
Modified: 2018-04-10 05:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: libguestfs-1.36.10-1.el7
Doc Type: Enhancement
Doc Text:
*virt-rescue* enhanced This release of the *virt-rescue* utility includes the following enhancements: * Ctrl+character sequences now act on commands run in *virt-rescue* and not on *virt-rescue* itself. * The `-i` option allows users to mount all disks after inspecting the guest.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0677 normal SHIPPED_LIVE libguestfs new packages, bug fix and enhancement update 2018-04-10 09:13:49 EDT

  None (edit)
Description Richard W.M. Jones 2017-04-04 05:07:31 EDT
Description of problem:

The new virt-rescue is much better than the old version.  In particular,
major bugs like ^C killing the whole program are fixed.  Also supports
`-i' to mount all the disks and an escape key.

Version-Release number of selected component (if applicable):

libguestfs-1.36.2-3.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Run: virt-rescue --scratch

Actual results:

Try using ^C - it will kill the whole program.

Expected results:

^C, ^Z should work as expected.

There is an escape key: try using ^] h

You can also do:

  $ virt-builder fedora-25
  $ virt-rescue -a fedora-25.img -i

and it should automatically mount the guest's disks under /sysroot
inside the rescue shell.
Comment 2 Richard W.M. Jones 2017-10-20 10:37:05 EDT
Backported patches are here:

https://github.com/libguestfs/libguestfs/commits/fedora-26
Comment 4 YongkuiGuo 2017-11-16 04:03:18 EST
Verified with package:
libguestfs-1.36.10-2.el7.x86_64

Steps:

1. #virt-rescue --scratch
--------------------------------------------------
...
The virt-rescue escape key is ‘^]’.  Type ‘^] h’ for help.

Welcome to virt-rescue, the libguestfs rescue shell.

Note: The contents of / (root) are the rescue appliance.
You have to mount the guest's partitions under /sysroot
before you can examine them.

bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
><rescue> ^]q
--------------------------------------------------

2. ^C and ^Z don't kill the rescue shell.

3. ^]q (an escape key) will exit the rescue shell successfully.

So verified this bug.
Comment 10 errata-xmlrpc 2018-04-10 05:15:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0677

Note You need to log in before you can comment on or make changes to this bug.