Bug 1438749 - Incorrect dependancies prevent network services from starting if Network Manager is not used.
Summary: Incorrect dependancies prevent network services from starting if Network Mana...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-04 11:02 UTC by Daniel Borek
Modified: 2018-02-19 15:48 UTC (History)
8 users (show)

Fixed In Version: systemd-219-33.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:14:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2297 normal SHIPPED_LIVE systemd bug fix and enhancement update 2017-08-01 12:40:16 UTC
Red Hat Knowledge Base (Solution) 2993361 None None None 2018-02-19 15:48:45 UTC

Description Daniel Borek 2017-04-04 11:02:16 UTC
Description of problem:

If Network Manager is not installed then services that want to listen on explicitly configured IP addresses are unable to start. Those services (including sshd, apache and others) depend on network.target and they fail because they're unable to bind to chosen IP addresses. There is an easy workaround for it:

systemctl add-wants multi-user.target network.target


Version-Release number of selected component (if applicable):
systemd-219-30.el7_3.6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make sure Network Manager is uninstalled.
2. In case of sshd, make sure this is in place:
ListenAddress 10.20.30.10 - any IP configured on the system would do

3. Boot the system

Actual results:

During system boot we see this:
sshd[423]: error: Bind to port 22 on 10.20.30.10 failed: Cannot assign requested address.

Expected results:
sshd and other services that use similar config to start fine

Additional info:

The issue is caused by missing dependancies and fix is already coded here:
https://github.com/systemd/systemd/pull/5652/files

Comment 2 Lukáš Nykrýn 2017-04-04 11:19:54 UTC
https://github.com/lnykryn/systemd-rhel/pull/102

Comment 5 Lukáš Nykrýn 2017-04-10 14:59:03 UTC
fix merged to upstream staging branch ->
https://github.com/lnykryn/systemd-rhel/commit/1649dac4656e8056e5fe5fa99e5753257efe1a42
-> post

Comment 9 errata-xmlrpc 2017-08-01 09:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297


Note You need to log in before you can comment on or make changes to this bug.