Bug 1438795 - ceilometer-wsgi in list of processes when passing enable_legacy_ceilometer_api = False in undercloud.conf
Summary: ceilometer-wsgi in list of processes when passing enable_legacy_ceilometer_ap...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-04 12:37 UTC by Sasha Smolyak
Modified: 2017-05-17 20:17 UTC (History)
6 users (show)

Fixed In Version: instack-undercloud-6.0.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:17:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 453270 None None None 2017-04-04 17:21:53 UTC

Description Sasha Smolyak 2017-04-04 12:37:47 UTC
Description of problem:
ceilometer-wsgi in list of undercloud processes when passing enable_legacy_ceilometer_api  = False in undercloud.conf

Version-Release number of selected component (if applicable):
openstack-ceilometer-notification-8.0.1-1.el7ost.noarch
openstack-ceilometer-polling-8.0.1-1.el7ost.noarch
openstack-ceilometer-collector-8.0.1-1.el7ost.noarch
openstack-ceilometer-central-8.0.1-1.el7ost.noarch
openstack-ceilometer-common-8.0.1-1.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. add enable_legacy_ceilometer_api  = False to undercloud.conf
2. Deploy undercloud
3. Observe list of httpd processes

Actual results:
ceilometer_wsgi is in the list

Expected results:
The process is not supposed to be there

Additional info:
Get a CRITICAL error in undercloud app.log:
CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Unable to establish connection to https://127.0.0.1:35357: HTTPSConnectionPool(host='127.0.0.1', port=35357): Max retries exceeded with url
: / (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7f55f3875190>: Failed to establish a new connection: [Errno 111] Connection refused',))

Need to verify it doesn't appear once the problem is fixed

Comment 3 Sasha Smolyak 2017-04-23 07:24:20 UTC
VErified, doesn't happen anymore. No errors in log as well.

Comment 4 errata-xmlrpc 2017-05-17 20:17:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.