Bug 1438869 - No SMBIOS nor DMI entry point found, sorry.
Summary: No SMBIOS nor DMI entry point found, sorry.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.4
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
: 1435430 1441680 1442425 1443277 1443915 (view as bug list)
Depends On:
Blocks: 1299988 1440030 1446211
TreeView+ depends on / blocked
 
Reported: 2017-04-04 15:28 UTC by John Sefler
Modified: 2017-08-01 19:22 UTC (History)
13 users (show)

Fixed In Version: subscription-manager-1.19.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1584 None closed 1438869: Clear dmidecode warnings 2020-03-16 17:00:47 UTC
Github candlepin subscription-manager pull 1596 None closed 1438869: Capture dmidecode errors at fact gathering 2020-03-16 17:00:48 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2017-04-04 15:28:34 UTC
Description of problem:
On some of the RHEL7.4 supported arches (aarch64, ppc64le, ppc64, s390x) (but NOT x86_64) dmidecode warnings like the following are being printed to stderr for many subscription-manager calls.

** COLLECTED WARNINGS **
/sys/firmware/efi/systab: SMBIOS entry point missing
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **

This is a regression from subscription-manager-1.17 behavior on RHEL7.3 and is causing many automated test failures due to the unexpected stderr messages.


Version-Release number of selected component (if applicable):
[root@hp-moonshot-03-c36 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.19.4-1.el7.aarch64
python-rhsm-1.19.2-1.el7.aarch64
[root@hp-moonshot-03-c36 ~]# rpm -qa | grep dmidecode
python-dmidecode-3.12.2-1.el7.aarch64
dmidecode-3.0-4.el7.aarch64


How reproducible:


Steps to Reproduce:
Use Beaker to reserve a RHEL74 aarch64, ppc64le, ppc64, s390x system, then run a subscription-manager command (e.g. subscription-manager version) and you will see unexpected warnings print to stderr...

HERE'S A FAILURE ON aarch64
[root@hp-moonshot-03-c36 ~]# uname -m
aarch64
[root@hp-moonshot-03-c36 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

** COLLECTED WARNINGS **
/sys/firmware/efi/systab: SMBIOS entry point missing
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **

[root@hp-moonshot-03-c36 ~]# 


HERE'S A FAILURE ON ppc64le
[root@ibm-p8-05-lp2 ~]# uname -m
ppc64le
[root@ibm-p8-05-lp2 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

** COLLECTED WARNINGS **
/dev/mem (mmap): Operation not permitted
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **

[root@ibm-p8-05-lp2 ~]# 


Actual results:
  above

Expected results:
  should not print list of ** COLLECTED WARNINGS ** / ** END OF WARNINGS **



Additional info:
Preliminary troubleshooting indicates that subscription-manager's dmiinfo code previously called dmidecode.clear_warnings() which probably suppressed printing of the COLLECTED WARNINGS.  These recent dbus pull requests are likely candidates that introduced this regression in behavior...
  https://github.com/candlepin/subscription-manager/pull/1509
  https://github.com/candlepin/subscription-manager/pull/1543

Comment 3 John Sefler 2017-04-04 15:46:09 UTC
Note: Despite the unexpected list of COLLECTED WARNINGS being printed to stderr, the subscription-manager modules are functioning well.  A consumer can still register and attach subscriptions.

Comment 4 Kevin Howell 2017-04-10 15:52:56 UTC
*** Bug 1435430 has been marked as a duplicate of this bug. ***

Comment 6 Valentina Mukhamedzhanova 2017-04-12 13:05:17 UTC
*** Bug 1441680 has been marked as a duplicate of this bug. ***

Comment 7 PaulB 2017-04-17 16:58:06 UTC
*** Bug 1442425 has been marked as a duplicate of this bug. ***

Comment 9 Rehana 2017-04-20 12:57:06 UTC
Retested with : 

# subscription-manager  version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7

** COLLECTED WARNINGS **
/sys/firmware/efi/systab: SMBIOS entry point missing
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **

[root@hp-moonshot-03-c37 ~]# uname -m
aarch64


I still see the warning messages

Comment 10 Rehana 2017-04-20 17:39:23 UTC
Reproduced the failure on RHEL 74 (RHEL-7.4-20170420.n.0) 

on aarch64:

[root@hp-moonshot-03-c13 ~]# uname -m
aarch64

[root@hp-moonshot-03-c13 ~]# subscription-manager  version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7

** COLLECTED WARNINGS **
/sys/firmware/efi/systab: SMBIOS entry point missing
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **


on s390x : 

[root@ibm-z-66 ~]# uname -m
s390x
[root@ibm-z-66 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7

** COLLECTED WARNINGS **
/dev/mem (mmap): Operation not permitted
No SMBIOS nor DMI entry point found, sorry.
** END OF WARNINGS **


Unable to get ppc64le and ppc64 machines from beaker as the request gets aborted. Based on the 2 failures above (on aarch64 and s390x)  moving the bug to New

Comment 11 Gustavo Luiz Duarte (IBM) 2017-04-20 19:49:51 UTC
*** Bug 1443915 has been marked as a duplicate of this bug. ***

Comment 12 Gustavo Luiz Duarte (IBM) 2017-04-20 19:54:46 UTC
*** Bug 1443277 has been marked as a duplicate of this bug. ***

Comment 14 Kevin Howell 2017-04-20 22:03:01 UTC
First fix attempt was insufficient, please retest against the latest build (subscription-manager-1.19.9-1).

Comment 15 John Sefler 2017-04-25 16:28:51 UTC
This issue was resolved in automated testruns for all arches of RHEL-7.4-Alpha-1.0 compose RHEL-7.4-20170421.1 with subscription-manager-1.19.9-1.el7

Moving to VERIFIED

Comment 16 IBM Bug Proxy 2017-05-11 07:40:24 UTC
------- Comment From hannsj_uhl@de.ibm.com 2017-05-11 03:36 EDT-------
Comment from  Harish Sriram 2017-05-10 23:49:12 CDT

Issue is not observed with latest release

# subscription-manager version
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

# uname -a
Linux ltc-garri1.aus.stglabs.ibm.com 4.11.0-1.el7.ppc64le #1 SMP Wed May 3 18:32:58 EDT 2017 ppc64le ppc64le ppc64le GNU/Linux

Comment 17 Hanns-Joachim Uhl 2017-05-11 07:46:15 UTC
oops ... the previous comment has to read:
"
Issue is not observed with latest release 

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

# uname -a
Linux ltc-garri1.aus.stglabs.ibm.com 4.11.0-1.el7.ppc64le #1 SMP Wed May 3
18:32:58 EDT 2017 ppc64le ppc64le ppc64le GNU/Linux
"
...

Comment 18 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.