Bug 1438879 - Set pacemaker property cluster-recheck-interval to lower value when pcmk-remote node deployed
Summary: Set pacemaker property cluster-recheck-interval to lower value when pcmk-remo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 11.0 (Ocata)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-04 15:51 UTC by Marian Krcmarik
Modified: 2017-05-17 20:17 UTC (History)
12 users (show)

Fixed In Version: puppet-tripleo-6.3.0-10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:17:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 453250 None None None 2017-05-03 11:25:55 UTC
OpenStack gerrit 454554 None None None 2017-04-07 06:40:56 UTC
Launchpad 1679753 None None None 2017-04-04 16:14:31 UTC

Description Marian Krcmarik 2017-04-04 15:51:08 UTC
Description of problem:
In the case pacemaker-remote (OS::TripleO::Services::PacemakerRemote profile) node is being deployed within composable roles topology we should lower pacemaker property of cluster-recheck-interval to much lower value from default value which is 15mins. The reason is that even though we set ocf:pacemaker:remote attribute reconnect_interval to 60s it's not guaranteed to be performed more frequently than the value of the cluster-recheck-interval cluster option and the consequence is that in a case of failover pacemaker_remote node is reported as down those 15mins at least even though it may be back online after fencing withint a minute.
We do set that property to 60s with Instance HA topology.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Deploy composable roles with a node which has OS::TripleO::Services::PacemakerRemote
2. Reset the node

Actual results:
Node is being reported as offline more than 15 minutes even though It comes back online within a minute

Expected results:
Quicker recovery.

Additional info:

Comment 1 Michele Baldessari 2017-04-07 06:40:56 UTC
Master merged. Linking the ocata backport here instead.

Comment 2 Marian Krcmarik 2017-05-12 15:32:13 UTC
Verified on puppet-tripleo-6.3.0-12. The property is set to 60 seconds once topology with remote pacemaker nodes is used.

Comment 4 errata-xmlrpc 2017-05-17 20:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.