Bug 143890 - libtool paths for g++ are stale
libtool paths for g++ are stale
Status: CLOSED DUPLICATE of bug 143889
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
Depends On:
  Show dependency treegraph
Reported: 2004-12-31 13:36 EST by Jonathan S. Shapiro
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-03 17:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2004-12-31 13:36:44 EST
Description of problem:

When building shared libraries using

   libtool --mode=link g++ -o foo.la ...objects... -rpath somedir

libtool attempts to reference to the crti files living in
/usr/lib/gcc/i386-redhat-linux/3.4.1/. This doesn't work, since both
gcc and g++ have been updated to versions 3.4.2 since the last update
of libtool.

Version-Release number of selected component (if applicable):


How reproducible:

   In a convenient FC3 shell and an empty directory
   Type: libtool --mode=link g++ -o fred.la fred.o -rpath /lib
   Watch the diagnostics to see that the wrong paths are referenced
Actual results:

Expected results:

   Well, I definitely don't expect that command to work, since
   there isn't any fred.o, but making reference to a bad path
   definitely wasn't the expected failure mode. :-)

Additional info:

   I rebuilt libtool locally by hand from the SRPM, deinstalled
   the fedora-supplied binary rpm and installed my newly built
   version. This "solved" the problem, so it looks like the
   existing libtool package may simply need to be
Comment 1 Daniel Reed 2005-01-03 17:57:54 EST

*** This bug has been marked as a duplicate of 143889 ***

Note You need to log in before you can comment on or make changes to this bug.