Bug 143896 - rhn-applet-gui wont connect.
rhn-applet-gui wont connect.
Status: CLOSED DUPLICATE of bug 143820
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-31 14:51 EST by Andrew D.
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D. 2004-12-31 14:51:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
	Hi,

	When I log in, my rhn icon in the gnome panel gives the 
message "checking for updates" but does not go beyond this. If I right 
click on it, all options except for exit are greyed out. If I run 
rhn-applet-gui from a gnome terminal I get the error below. If I run 
rhn-applet-tui, eveything seems to work fine. Also, up2date seems to 
work fine. One thing I notice is that the uuid in 
/etc/sysconfig/rhn/rhn-applet file is different than the rhnuuid in 
the /etc/sysconfig/rhn/up2date-uuid file. I have reinstalled both 
python and rhn-applet and the problem is still there. I think this 
started after I updated to RHEL3.4 from RHEL3.3 via up2date. Here are 
the versions for the relevant programs:
RHEL 3.0 WS
python-2.2.3-6
rhn-applet-2.1.18-4
(BTW, my RHN account has not expired)

Thank you in advance for any help.

	--Andrew



Version-Release number of selected component (if applicable):
rhn-applet-2.1.18-4

How reproducible:
Always

Steps to Reproduce:
1.run rhn-applet-gui
2.
3.
    

Actual Results:  I get the error message below.

Expected Results:  It should connect to RHN.

Additional info:

ERROR MESSAGE:
Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 460, in 
refresh_handler
    self.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 577, in 
refresh
    if self.nag_check():
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 538, in 
nag_check
    bc = self.model.has_base_channel()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line 335, 
in has_base_channel
    base_channel = source.has_base_channel()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 181, 
in has_base_channel
    raise rhnAppletRPCFault(f.faultCode, f.faultString)
rhn_utils.rhnAppletRPCFault: Server Communication Error -140: 
Error Message:
    Your system was not found in the RHN database
Error Class Code: 140
Error Class Info: Unable to look up server
Comment 1 Andrew D. 2004-12-31 15:10:51 EST

*** This bug has been marked as a duplicate of 143820 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.