Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1439 - printing BW with a deskjet 500c not working properly
printing BW with a deskjet 500c not working properly
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-06 14:31 EST by Mike Maher
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-12 10:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Maher 1999-03-06 14:31:41 EST
It appears that the deskjet 500c filter in the 5.2
distribution does not
work correctly when configured to print BW.  I struggled
with this a bit
only to find that

1) the color mode worked fine

2) the non-color deskjet filter works fine for BW (this was
my workaround)

3) if I use the 500C filter it works okay for BW text, but
when handed postscript gs appears to balk with the error:

Unrecoverable error: rangecheck in .putdeviceprops
(1488) op_array(486)0x817b0d4:E... (after the E falls off
the page -
sorry)
Comment 1 Bill Nottingham 1999-03-08 14:16:59 EST
don't use 1bpp. Use 8bpp instead. (that's still B&W).

The ghostscript driver suddenly became broken.
Comment 2 Bill Nottingham 1999-03-22 18:50:59 EST
at some point I'll attempt to fix ghostcript, when I have
copious amounts of free time, or a better understanding of
the ghostscript code. Until then, this falls under a 'don't do that.'
Comment 3 Jay Turner 1999-06-29 14:19:59 EDT
Bill, what is the status of this currently??
Comment 4 Bill Nottingham 1999-06-29 14:23:59 EDT
the ghostscript driver is still doesn't like to be configured
for 1bpp, AFAIK. Haven't looked at it recently. New installs
won't be configured to use it; upgrades could run into this issue
though.

Note You need to log in before you can comment on or make changes to this bug.