Bug 143901 - RFE: Please include hplip in FC5
RFE: Please include hplip in FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Bill Nottingham
http://sourceforge.net/forum/forum.ph...
: FutureFeature
: 149775 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2004-12-31 19:15 EST by Dawid Gajownik
Modified: 2014-03-16 22:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 10:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposal spec file (3.55 KB, text/plain)
2004-12-31 19:19 EST, Dawid Gajownik
no flags Details
Errors from install script (2.63 KB, text/plain)
2004-12-31 19:28 EST, Dawid Gajownik
no flags Details

  None (edit)
Description Dawid Gajownik 2004-12-31 19:15:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5)
Gecko/20041122

Description of problem:
http://hpinkjet.sourceforge.net/ released a new drivers to HP
products. I would be nice to include then in FC4 :)

Version-Release number of selected component (if applicable):
hplip

How reproducible:
Always

Steps to Reproduce:
1. yum install hplip -> hplip not found ;)    

Additional info:
Happy New Year!
Comment 1 Dawid Gajownik 2004-12-31 19:19:55 EST
Created attachment 109205 [details]
Proposal spec file

Well, it's my 3rd spec file in my whole life, so I think that it need to be
polished :D
Comment 2 Dawid Gajownik 2004-12-31 19:28:20 EST
Created attachment 109206 [details]
Errors from install script

Oh, I almost forgot - when you install package without "--enable-rpm-install"
option, you will see those errors. That's why I had to write so many lines in
%install section.
Comment 3 Dawid Gajownik 2005-01-01 07:43:55 EST
I had a sleep and now I see that I missed two things:
- Obsoletes: hpijs
- hplip should be split into two packages - driver and the GUI app.
Now hplip requires X server :/
Comment 4 Bill Nottingham 2005-01-03 01:18:51 EST
Tim, how does this relate to both hpijs and hpoj?
Comment 5 Tim Waugh 2005-01-04 04:20:04 EST
It's newer than both.  I'm watching it already, but waiting until the "new
project" bugs are shaken out before switching Fedora Core over to it.
Comment 6 Jeff Moe (jebba) 2005-02-02 16:35:36 EST
Tim, can you put it in rawhide so it can be tested?

Bill: "A distribution can mix and match the HPLIP package in order to
support a un-di or bi-di solution. HPIJS is part of the HPLIP package.

HPLIP is intended to replace HPOJ for all local USB and JetDirect
connectivity. HPLIP is similar to HPOJ, but different. HPLIP has
persistent daemons (hpiod, hpssd) like HPOJ, but is more friendly.
HPLIP does not require a ptal-init setup. The "hp" backend will look
like any other CUPS backend that can be installed as needed. The
daemons use a standard init.d start/stop script." 
http://hpinkjet.sourceforge.net/hplip_readme.html
Comment 7 Tim Waugh 2005-02-02 17:07:50 EST
It's quite a bit work than just dumping the RPM in.  When I get some
time I will take a look, but it might miss FC4.
Comment 8 Tim Waugh 2005-04-06 08:08:56 EDT
*** Bug 149775 has been marked as a duplicate of this bug. ***
Comment 9 Tim Waugh 2005-06-03 08:17:28 EDT
Retargetting for FC5.
Comment 10 Dawid Gajownik 2005-06-09 10:29:40 EDT
Fixed in Rawhide :D

Note You need to log in before you can comment on or make changes to this bug.