Bug 143903 - post macros are not compat with other versions of bash
Summary: post macros are not compat with other versions of bash
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-01 01:00 UTC by Jeff Pitman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 08:13:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (587 bytes, patch)
2005-01-01 01:00 UTC, Jeff Pitman
no flags Details | Diff

Description Jeff Pitman 2005-01-01 01:00:16 UTC
Description of problem:  
  
bash 2.05a (rh73, rhel2.1) returns 1 when unsetting an environment variable  
that is non-existent.  bash 2.05b+ (rh9+) returns 0.  Current script behavior  
depends on bash 2.05b+.  
  
Steps to Reproduce:  
1. Install redhat-rpm-config on rh73 (fedora legacy applicable) or rhel2.1.  
2. Build package. 
3. Fails when script executes "unset DISPLAY".

Comment 1 Jeff Pitman 2005-01-01 01:00:16 UTC
Created attachment 109208 [details]
Proposed patch

Comment 2 Florian La Roche 2005-01-25 08:13:07 UTC
Doesn't make sense to mix rpm-config with such old releases, I'll
close this report.


Comment 3 Jeff Pitman 2005-01-25 09:33:47 UTC
For the record, rpm-config does work on 7.3 and creates debuginfo      
packages like later releases. Were it not for "unset DISPLAY", it   
would work fine. Not fixing it because the distro needs to be   
forward-looking is another issue and is most certainly acceptable.  


Note You need to log in before you can comment on or make changes to this bug.