Bug 1439051 - Anaconda hang with GDBus.Error ...UnknownMethod for PowerPC F26 ks install
Summary: Anaconda hang with GDBus.Error ...UnknownMethod for PowerPC F26 ks install
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 26
Hardware: ppc64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1439388 (view as bug list)
Depends On:
Blocks: PPCTracker F26BetaBlocker F26PPCBeta
TreeView+ depends on / blocked
 
Reported: 2017-04-05 06:04 UTC by Michel Normand
Modified: 2017-04-28 13:15 UTC (History)
10 users (show)

(edit)
Clone Of:
: 1439220 (view as bug list)
(edit)
Last Closed: 2017-04-13 14:08:00 UTC


Attachments (Terms of Use)
_boot_to_anaconda-anaconda.log (1.85 KB, text/plain)
2017-04-05 07:12 UTC, Michel Normand
no flags Details
_boot_to_anaconda-syslog.log (259.25 KB, text/plain)
2017-04-05 07:14 UTC, Michel Normand
no flags Details
_boot_to_anaconda-storage.log (273 bytes, text/plain)
2017-04-05 07:15 UTC, Michel Normand
no flags Details
_boot_to_anaconda-program.log (964 bytes, text/plain)
2017-04-05 07:18 UTC, Michel Normand
no flags Details
_boot_to_anaconda-var_log.tar.gz (2.20 KB, application/x-gzip)
2017-04-05 07:20 UTC, Michel Normand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1439388 None CLOSED Kickstart installs sometimes die with traceback ending in gdbus error 2019-05-22 08:31 UTC

Internal Trackers: 1439388

Description Michel Normand 2017-04-05 06:04:40 UTC
Anaconda hang with GDBus.Error ...UnknownMethod for PowerPC F26 ks install

for QA ks tests (like QA:Testcase_kickstart_firewall_configured or QA:Testcase_kickstart_firewall_disabled ...)


The problem started with f26 compose 20170403 (no failure with 20170331)
The same problem is still alive with 20170404

===
anaconda 26.21.1-1 for Fedora 26 (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separarate Text/plain attachments
Traceback (most recent call last):
  File "/sbin/anaconda", line 582, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 1353, in networkInitialize
    logIfcfgFiles(msg)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/network.py", line 239, in logIfcfgFiles
    ifcfglog.debug("all settings: %s", nm.nm_get_all_settings())
  File "/usr/lib64/python3.6/site-packages/pyanaconda/nm.py", line 760, in nm_get_all_settings
    settings = proxy.GetSettings()
  File "/usr/lib64/python3.6/site-packages/gi/overrides/Gio.py", line 172, in __call__
    None)
Glib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.NetworkManager.Settings.Connection' on object at path /org
/freedesktop/NetworkManager/Settings/2 (19)
===

Comment 1 Michel Normand 2017-04-05 07:02:49 UTC
seems to be a timing problem, because if test triggered again the day after then there is no more such hang situation.

Comment 2 Michel Normand 2017-04-05 07:12 UTC
Created attachment 1268867 [details]
_boot_to_anaconda-anaconda.log

Comment 3 Michel Normand 2017-04-05 07:14 UTC
Created attachment 1268868 [details]
_boot_to_anaconda-syslog.log

Comment 4 Michel Normand 2017-04-05 07:15 UTC
Created attachment 1268869 [details]
_boot_to_anaconda-storage.log

Comment 5 Michel Normand 2017-04-05 07:18 UTC
Created attachment 1268872 [details]
_boot_to_anaconda-program.log

Comment 6 Michel Normand 2017-04-05 07:20 UTC
Created attachment 1268873 [details]
_boot_to_anaconda-var_log.tar.gz

Comment 7 Radek Vykydal 2017-04-05 07:26:25 UTC
We are seeing the traceback also in current rhel7-branch. It seems we need to handle connections which become invalid (by some NM event) between obtaining the connection path and trying to read the settings of the connection for the path.

Comment 8 Michel Normand 2017-04-05 14:27:52 UTC
refer to new clone https://bugzilla.redhat.com/show_bug.cgi?id=1439220
and old ref https://bugzilla.redhat.com/show_bug.cgi?id=1394579

Comment 9 Radek Vykydal 2017-04-06 11:23:24 UTC
https://github.com/rhinstaller/anaconda/pull/1014

Comment 10 Fedora Update System 2017-04-11 14:50:44 UTC
anaconda-26.21.3-1.fc26 blivet-gui-2.1.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-10db06fadf

Comment 11 Fedora Update System 2017-04-12 23:21:36 UTC
anaconda-26.21.3-1.fc26, blivet-gui-2.1.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-10db06fadf

Comment 12 Fedora Update System 2017-04-13 14:08:00 UTC
anaconda-26.21.3-1.fc26, blivet-gui-2.1.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Michel Normand 2017-04-13 14:19:43 UTC
I am waiting for the change to be part of a new f26 compose

Comment 14 Radek Vykydal 2017-04-28 09:02:37 UTC
*** Bug 1439388 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2017-04-28 13:15:52 UTC
anaconda-26.21.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2


Note You need to log in before you can comment on or make changes to this bug.