Bug 1439111 - gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-209 doesn't exist.
gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-209 doesn't...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libblockdev (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
abrt_hash:2d64d8cc1f954ce5265aef4dec6...
:
: 1443608 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-05 05:10 EDT by Jakub Vavra
Modified: 2017-04-19 10:38 EDT (History)
12 users (show)

See Also:
Fixed In Version: libblockdev-2.6-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-13 10:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (218.52 KB, text/plain)
2017-04-05 05:10 EDT, Jakub Vavra
no flags Details
File: environ (529 bytes, text/plain)
2017-04-05 05:10 EDT, Jakub Vavra
no flags Details
File: lsblk_output (2.05 KB, text/plain)
2017-04-05 05:10 EDT, Jakub Vavra
no flags Details
File: nmcli_dev_list (1.79 KB, text/plain)
2017-04-05 05:10 EDT, Jakub Vavra
no flags Details
File: os_info (447 bytes, text/plain)
2017-04-05 05:10 EDT, Jakub Vavra
no flags Details
anaconda.log (58.39 KB, text/plain)
2017-04-10 15:35 EDT, Vojtech Trefny
no flags Details
program.log (35.19 KB, text/plain)
2017-04-10 15:35 EDT, Vojtech Trefny
no flags Details
storage.log (127.20 KB, text/plain)
2017-04-10 15:36 EDT, Vojtech Trefny
no flags Details
syslog (219.76 KB, text/plain)
2017-04-10 15:36 EDT, Vojtech Trefny
no flags Details
anaconda-tb (813.58 KB, text/plain)
2017-04-10 15:37 EDT, Vojtech Trefny
no flags Details

  None (edit)
Description Jakub Vavra 2017-04-05 05:10:00 EDT
Description of problem:
Did reinstallation of F26.
Used btrfs in raid.
Re-created encrypted swap on partition.

Version-Release number of selected component:
anaconda-26.21.1-1

The following was filed automatically by anaconda:
anaconda 26.21.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 745, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.6/site-packages/blivet/devices/md.py", line 488, in _setup
    blockdev.md.activate(self.path, members=disks, uuid=self.mdadm_format_uuid)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 377, in setup
    self._setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 695, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 437, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 471, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install.py", line 356, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self, *args, **kwargs)
gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-209 doesn't exist.

Additional info:
addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        26
Comment 1 Jakub Vavra 2017-04-05 05:10:06 EDT
Created attachment 1268898 [details]
File: anaconda-tb
Comment 2 Jakub Vavra 2017-04-05 05:10:08 EDT
Created attachment 1268899 [details]
File: environ
Comment 3 Jakub Vavra 2017-04-05 05:10:09 EDT
Created attachment 1268900 [details]
File: lsblk_output
Comment 4 Jakub Vavra 2017-04-05 05:10:11 EDT
Created attachment 1268901 [details]
File: nmcli_dev_list
Comment 5 Jakub Vavra 2017-04-05 05:10:12 EDT
Created attachment 1268902 [details]
File: os_info
Comment 6 Jakub Vavra 2017-04-05 07:11:59 EDT
Similar problem has been detected:

Reinstallation of F26.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-209 doesn't exist.
release:        Cannot get release name.
version:        26
Comment 7 Jakub Vavra 2017-04-05 07:24:11 EDT
Similar problem has been detected:

Tried to reinstall F26, this time without using blivet-gui.
Did auto partitioning +  encrypted +reclaim space/delete all.
After I have started installation I got the exception.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-209 doesn't exist.
release:        Cannot get release name.
version:        26
Comment 8 Jakub Vavra 2017-04-05 08:28:31 EDT
Similar problem has been detected:

Reinstall of F26 where previously raid 0 was present on two of 3 drives.
Used automatic partitioning + reclaim space/delete all.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_unused-4-212 doesn't exist.
release:        Cannot get release name.
version:        26
Comment 9 Jiri Kortus 2017-04-06 05:31:37 EDT
Similar problem has been detected:

I had a VM with two disks containing partitioning from previous installation, /boot on vda, swap on vdb, and two RAID devices spread across the two disks (for / and /home). I run installation of Fedora 26 Alpha Server, entered blivet-gui partitioning, deleted the RAID device for / (previously with a label 'fedora') and created a new one (with a label 'root') in blivet-gui. The device appeared in the list, but with the old label ('fedora'). Despite this, I continued with installation, which however ended up with a traceback.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora doesn't exist.
release:        Cannot get release name.
version:        26
Comment 10 Petr Schindler 2017-04-06 07:28:07 EDT
Similar problem has been detected:

I tried delete partitions on the disks and create new one.

There are three disks. Previous layout was: two raid partitions (one raid0 and the second raid5) created on all three disks,
then on sda wer /boot and swap partitions.

I tried to create the same layout.

It is possible, that the previous formating didn't finish correctly because my laptop froze during the installation (I'm not sure when).

addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
other involved packages: python3-blockdev-2.5-1.fc26.x86_64, python3-blivet-2.1.7-8.fc26.noarch, system-python-libs-3.6.0-21.fc26.x86_64
package:        anaconda-core-26.21.1-1.fc26.x86_64
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_localhost-live_0 doesn't exist.
release:        Fedora release 26 (Twenty Six)
version:        26
Comment 11 Martin Kolman 2017-04-06 09:24:18 EDT
Similar problem has been detected:

Did the sfotware raid test case followed by the btrfs test case.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc4.git0.1.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/REID doesn't exist.
release:        Cannot get release name.
version:        26
Comment 12 Jiri Kortus 2017-04-06 10:19:06 EDT
Similar problem has been detected:

I tried to install Fedora 26 Alpha Server x86_64 on a system with two disks containing partitioning from previous installation (with RAID members), using plain XFS partitions for /boot and /, but it ended up with traceback, most probably related to the previously used partitioning.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora doesn't exist.
release:        Cannot get release name.
version:        26
Comment 13 Martin Kolman 2017-04-10 07:59:30 EDT
Similar problem has been detected:

Tried to reuse an existing software raid for /.

addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc5.git0.1.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         gi.overrides.BlockDev.MDRaidError: Device /dev/md/fedora_office85 doesn't exist.
release:        Cannot get release name.
version:        26
Comment 14 David Lehman 2017-04-10 14:55:22 EDT
Anyone who can reproduce this and attach a corresponding full set of logs, it would be appreciated. The original logs are missing the storage, anaconda, and program logs.

 /tmp/anaconda-tb-*
 /tmp/anaconda.log
 /tmp/storage.log
 /tmp/program.log
 /tmp/syslog

Thanks in advance.
Comment 15 Vojtech Trefny 2017-04-10 15:35 EDT
Created attachment 1270572 [details]
anaconda.log
Comment 16 Vojtech Trefny 2017-04-10 15:35 EDT
Created attachment 1270573 [details]
program.log
Comment 17 Vojtech Trefny 2017-04-10 15:36 EDT
Created attachment 1270574 [details]
storage.log
Comment 18 Vojtech Trefny 2017-04-10 15:36 EDT
Created attachment 1270575 [details]
syslog
Comment 19 Vojtech Trefny 2017-04-10 15:37 EDT
Created attachment 1270576 [details]
anaconda-tb
Comment 20 Vojtech Trefny 2017-04-10 15:40:24 EDT
This was originally reported with blivet-gui, but this happens also when using custom spoke.

Steps to reproduce:

1. Try to reuse an existing MD array for /

We are actually stopping the array in some step during the installation and that of course prevents us from reusing it later. From program.log:

19:13:04,668 INFO program: Running [14] mdadm --stop /dev/md/fedora ...
19:13:04,716 INFO program: stdout[14]: 
19:13:04,719 INFO program: stderr[14]: mdadm: stopped /dev/md/fedora
Comment 21 Vojtech Trefny 2017-04-12 04:13:07 EDT
https://github.com/rhinstaller/libblockdev/pull/183
Comment 22 Fedora Update System 2017-04-12 07:08:53 EDT
libblockdev-2.6-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d9edbb80a7
Comment 23 Fedora Update System 2017-04-12 19:23:11 EDT
libblockdev-2.6-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d9edbb80a7
Comment 24 Fedora Update System 2017-04-13 10:08:43 EDT
libblockdev-2.6-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 25 Vojtech Trefny 2017-04-19 10:38:22 EDT
*** Bug 1443608 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.