Bug 1439203 - [Ansible-UI]: Improve task name for Ansible tasks.
Summary: [Ansible-UI]: Improve task name for Ansible tasks.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: James Wong
QA Contact: Dmitry Misharov
URL:
Whiteboard: ui:task:ansible
Depends On: 1506796 1509141
Blocks: 1440573
TreeView+ depends on / blocked
 
Reported: 2017-04-05 12:30 UTC by Satyajit Bulage
Modified: 2018-03-06 14:53 UTC (History)
9 users (show)

Fixed In Version: 5.9.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1440573 (view as bug list)
Environment:
Last Closed: 2018-03-06 14:53:47 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing actual results (151.32 KB, image/png)
2017-04-05 12:30 UTC, Satyajit Bulage
no flags Details

Description Satyajit Bulage 2017-04-05 12:30:37 UTC
Created attachment 1268946 [details]
Screenshot showing actual results

Description of problem: Adding ansible repository, the task is created but Task Name is not showing properly. See attached screenshot.

Version-Release number of selected component (if applicable):5.8.0.9-alpha2.20170404195944_1d7ece4


How reproducible:100%


Steps to Reproduce:
1. Navigate to Automation--> Ansible --> Repository
2. Add repository.
3. Navigate to User drop-down--> Configuration --> Tasks

Actual results: Task Name is not showing properly


Expected results: Task Name should have proper name.


Additional info:

Comment 3 CFME Bot 2017-04-07 18:51:49 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c82a0851b8b356cedd6a06dc1ac31a2a60127da6

commit c82a0851b8b356cedd6a06dc1ac31a2a60127da6
Author:     James Wong <jwong@redhat.com>
AuthorDate: Thu Apr 6 18:52:33 2017 -0400
Commit:     James Wong <jwong@redhat.com>
CommitDate: Thu Apr 6 18:52:33 2017 -0400

    Fix/improve name for tasks that do CUD Tower project/credential
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1439203

 .../providers/ansible_tower/shared/automation_manager/tower_api.rb  | 6 +++---
 .../automation_manager/configuration_script_source.rb               | 4 ++--
 spec/support/ansible_shared/automation_manager/credential.rb        | 4 ++--
 3 files changed, 7 insertions(+), 7 deletions(-)

Comment 9 CFME Bot 2017-10-19 00:09:52 UTC
New commit detected on ManageIQ/manageiq-api/master:
https://github.com/ManageIQ/manageiq-api/commit/8142a460f6403361b5ca4c8c712b53ca61df52fa

commit 8142a460f6403361b5ca4c8c712b53ca61df52fa
Author:     James Wong <jwong@redhat.com>
AuthorDate: Wed Oct 18 17:18:48 2017 -0400
Commit:     James Wong <jwong@redhat.com>
CommitDate: Wed Oct 18 17:18:57 2017 -0400

    symbolize parameters before sending to backend
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1439203

 app/controllers/api/configuration_script_sources_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 10 James Wong 2017-10-19 00:28:49 UTC
The new PR just got merged is fixing the missed project name in the "Task Name" column. This particular issue is only applicable to project (e.g. authentication is not affected). The cause is that the API doesn't send to backend the agreed format of the project name and so backend can't log it properly.

Comment 11 James Wong 2017-10-19 13:35:09 UTC
Satyajit,

Other than the missing Project name in the 'Task Name' column, what else you are looking for improvement?

regards,
James

Comment 17 Dmitry Misharov 2017-12-01 07:14:01 UTC
Verified in 5.9.0.11.20171127204214_e316988.


Note You need to log in before you can comment on or make changes to this bug.