Bug 1439216 - Unable to allocate 32GB of RAM to Windows 10x64
Summary: Unable to allocate 32GB of RAM to Windows 10x64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ovirt-4.2.0
: ---
Assignee: jniederm
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1447236
TreeView+ depends on / blocked
 
Reported: 2017-04-05 12:51 UTC by Jaroslav Spanko
Modified: 2021-06-10 12:12 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1447236 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:41:54 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:43:01 UTC
oVirt gerrit 75304 0 master MERGED core: Win 10 x64 guest OS inherits from Win 8 x64 2017-04-09 12:41:40 UTC
oVirt gerrit 75410 0 ovirt-engine-4.1 MERGED core: Win 10 x64 guest OS inherits from Win 8 x64 2017-04-12 09:21:35 UTC

Description Jaroslav Spanko 2017-04-05 12:51:00 UTC
Description of problem:

It is not possible to allocate more than 20GB of RAM when is OS Type Windows 10x64 set.
Error messages:
Cannot edit VM. Maximum memory cannot exceed platform limit.
Cannot run VM. Memory size exceeds supported limit for given cluster version.

Version-Release number of selected component (if applicable):
RHV 4.x

How reproducible:
100%

Steps to Reproduce:
1. Allocate more than 20GB of RAM to VM
2. Error message about the exceed limit appears

engine.log
2017-04-05 09:51:42,579 WARN [org.ovirt.engine.core.bll.RunVmCommand] (default task-24) [27a49aa5] Validation of action 'RunVm' failed for user Reasons: VAR__ACTION__RUN,VAR__TYPE__VM,ACTION_TYPE_FAILED_MEMORY_EXCEEDS_SUPPORTED_LIMIT

Actual results:
Not possible for Windows 10x64

Expected results:
Able to allocate > 20GB of RAM

Additional info:
This is possible if OS Type is set to Other or Windows[7,8,2012,2016]x64

Thank you

Comment 2 rhev-integ 2017-04-26 10:50:14 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[FOUND CLONE FLAGS: ['rhevm-4.1.z', 'rhevm-4.2-ga'], ]

For more info please contact: rhv-devops@redhat.com

Comment 5 Israel Pinto 2017-11-14 08:11:49 UTC
Verify with:
Software version:4.2.0-0.0.master.20171108151837.gita7de53e.el7.centos

Steps:
Create windows 10 64bit V and set memory to 32GB and run vm
Results:
VM is up
No errors

Comment 8 Yaniv Kaul 2017-12-18 10:20:32 UTC
Israel, what about 2008 32b?

Comment 9 Israel Pinto 2017-12-18 10:45:30 UTC
(In reply to Yaniv Kaul from comment #8)
> Israel, what about 2008 32b?

windows 2008 32B is derived from other 
(going through windows 2003 --> XP --> other)

os.other.resources.minimum.ram.value = 256
os.other.resources.maximum.ram.value = 65536
  

# Windows2003(3, OsType.Windows, false),
os.windows_2003.derivedFrom.value = windows_xp


# Windows2008(4, OsType.Windows, false),
os.windows_2008.derivedFrom.value = windows_2003

So it looks like bug in configuration should be 32B according to:
https://msdn.microsoft.com/en-us/library/windows/desktop/aa366778(v=vs.85).aspx

Comment 17 errata-xmlrpc 2018-05-15 17:41:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 18 Franta Kust 2019-05-16 13:03:28 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.