Bug 143933 - Duplicate tcp line warnings in netstat
Duplicate tcp line warnings in netstat
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 16:22 EST by Brian Bruns
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 05:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Bruns 2005-01-01 16:22:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041220 K-Meleon/0.9

Description of problem:
When doing a netstat output of all active connections on a server, I
am getting "warning, got duplicate tcp line." mixed in with the
regular connection listings.  See example:

tcp        0      1 natasha.ahbl.org:64137     
240.wfc.nycm.n54ny05r:32723 SYN_SENT
tcp        0      1 natasha.ahbl.org:64227      12.111.132.186:33539 
      SYN_SENT
tcp        0      1 natasha.ahbl.org:64146     
178.muaab.cmbr.bstma0:32723 SYN_SENT
warning, got duplicate tcp line.
warning, got duplicate tcp line.
warning, got duplicate tcp line.
tcp        0      1 natasha.ahbl.org:64154     
24.we1.phnx.ls3ca31ur:32723 SYN_SENT
tcp        0      1 natasha.ahbl.org:64245      12.109.79.13:33539   
      SYN_SENT

Possibly related to change made in bugzilla entry #139407, "Add
filtering for duplicate entries in netstat".

Version-Release number of selected component (if applicable):
net-tools-1.60-42

How reproducible:
Always

Steps to Reproduce:
1. Run the command 'netstat'

    

Additional info:

Kernel is 2.6.9-ac11 (source extracted from Fedora Core devel kernel
SRPM with misc patches included - will have to find the specific
version of the release if you need it) on an AthlonXP 2000+
Comment 1 Radek Vokal 2005-01-03 04:41:57 EST
Well, this is the correct behaviour. The warning goes to stderr, so
the workaround for you is to redir the stderr output somewhere else. 
Comment 2 Orion Poplawski 2005-04-11 17:25:15 EDT
Is the any point to having the warning output?  Is this indicative of a problem
that needs to be fixed?  If not, then they should be supressed by default, IMO.
Comment 3 Radek Vokal 2005-04-12 02:17:59 EDT
That's true. I'm will probably move these messages to a system log rather than
stderr.
Comment 4 Stefan Neufeind 2005-04-24 12:50:00 EDT
Hmm, still experiencing this on latest FC3-kernel. What is the cause for this
error? Sure not the error-output but the error is to be fixed :-)
Comment 5 Radek Vokal 2005-04-25 02:15:45 EDT
The problem is in nonexistence of some kind of lock between the /proc/net file
and netstat. So when there're rapid changes in /proc/net file, reading the input
line by line causes line duplicates. So I won't clasify this as a kernel bug .. 
Comment 6 Radek Vokal 2005-04-26 05:35:18 EDT
Anyway, I've supressed the warning in next rawhide build - net-tools-1.60-52

Note You need to log in before you can comment on or make changes to this bug.