Bug 1439355 - [librbd] is_exclusive_lock_owner doesn't detect that is has been blacklisted
Summary: [librbd] is_exclusive_lock_owner doesn't detect that is has been blacklisted
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Jason Dillaman
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords: CodeChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-05 19:17 UTC by Jason Dillaman
Modified: 2017-07-30 15:36 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:31:40 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 19468 None None None 2017-04-05 19:17 UTC

Description Jason Dillaman 2017-04-05 19:17:45 UTC
Description of problem:
The librbd API's "is_exclusive_lock_owner" does not properly detect when a client has been blacklisted.

Version-Release number of selected component (if applicable):
2.2

How reproducible:
100%

Steps to Reproduce:
1. use the API directly
2. acquire exclusive lock on image
3. blacklist image
4. test exclusive lock ownership status

Actual results:
API doesn't detect the blacklist and loss of exclusive lock

Expected results:
API should detect that is was blacklisted

Additional info:

Comment 2 Jason Dillaman 2017-04-05 19:18:54 UTC
This fix is required for low-level RBD/iSCSI integration via TCMU

Comment 7 vidushi 2017-05-23 11:11:46 UTC
(In reply to Jason Dillaman from comment #0)
> Description of problem:
> The librbd API's "is_exclusive_lock_owner" does not properly detect when a
> client has been blacklisted.
> 
> Version-Release number of selected component (if applicable):
> 2.2
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. use the API directly
> 2. acquire exclusive lock on image
> 3. blacklist image
> 4. test exclusive lock ownership status
> 
> Actual results:
> API doesn't detect the blacklist and loss of exclusive lock
> 
> Expected results:
> API should detect that is was blacklisted
> 
> Additional info:

@Jason,
Can you please share the procedure to blacklist the image?

Comment 8 Jason Dillaman 2017-05-23 13:45:37 UTC
@Vidushi: this BZ was flagged as CodeChange since it really isn't testable (since it requires using the API directly).

Comment 12 errata-xmlrpc 2017-06-19 13:31:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.